Bug 26782 - Fisher iso image will not boot or install
Fisher iso image will not boot or install
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Erik Troan
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-08 23:43 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-24 10:49:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-02-08 23:43:13 EST
Am using Redhat 7.0 floppy to boot with Fisher in cd drive
Installing laptop
(have tried all except upgrade)
Will install all packages and start post install

Get the following message

Traceback(innermost last):

File "var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py", line 19,
in run
rc = self.todo.doInstall()

File "var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 2001, in
doInstall self.upgrade)

File "var/tmp/anaconda-7.1/usr/lib/anaconda/lilo.py", line 353, in
install
	if (needsEnterpriseKernel() and hdList.has_key('kernel-enterprise')
and
File"/var/tmp/anaconda-7.1//usr/lib/anaconda/lilo.py", line 10,
in needsEnterpriseKernel
	f=open("/proc/e820info","r")
IOERROR: [Erron 2] No such file or directory: '/proc/e820info'

Am left with a unusable system
Comment 1 Need Real Name 2001-02-09 16:15:48 EST
Just tried upgrade on crippled system from last install attempt.
On upgrade examine got the following message:

Traceback (innermost last):
	File "/usr/bin/anaconda", line 503, in ?
	intf.run(todo, test = test)

	File "var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py",line 372, in run
self.icw.run()

	File "var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py",line 851, in run
mainloop()

	File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
_gtk.gtk_mainloop()

	File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in__call__
ret = apply(self.func,a)

	File "/var/tmp/anaconda-7.1//usr/lib/anaconda/gui.py", line 462, in
nextClicked
	next = self.currentScreen.getNext()

	File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1080, in
upgradeFindPackages
	allowDirty = 0)

	File "/var/tmp/anaconda-7.1//usr/lib/anaconda/upgrade,py", line 100
in mountRootPartition
	intf.messageWindow(("Dirty filesystems"),
NameError:intf
Comment 2 Joey Welt 2001-02-09 20:02:41 EST
using a fisher standard boot.img floppy, installing from a vfat partition on my 
existing hard drive i receive the same error as above. (first report)

the target is a Laptop; Toshbia Portege 7200ct
the pcmcia boot floppy fails to find the Addonics pcmcia cd drive (410t-ad)
the error occurs after i choose my video card (which is now supported in 4.02 
but is not listed in the drop down), the Trident Cyberblade/e4-128 (Cyber9540 
chipset)
Comment 3 Joey Welt 2001-02-10 11:45:31 EST
can i repicate it?:  - yes
1.  start setup using any type (custom, laptop, etc)
2.  when prompted for vidio card selection, choose generic svga _or_ cyberblade
(generic).
3.  watch it fail. 

==================================
anacondadump.txt can be found at
==================================
http://www.reddisciples.net/anacdump.txt
Comment 4 Michael Fulbright 2001-02-11 22:27:52 EST
The 'dirty filesystem' error has been fixed - you need to boot your system and
have it run fsck to cleanup the filesystems.

I'm not sure about your original problem. Could you give the specifics of your
system please.

To the other bug reporters - please open a new bug with your reports.
Comment 5 Need Real Name 2001-02-12 10:34:42 EST
Original machine was Toshiba 2105CDS.
Fisher CD #1 would not boot or complete the installation process.
Would fail on post installation.

Have since tried on another machine with the same result except CD #1 would 
boot.
Next machine is generic Pentium 3 450 mhz. But has 2 video cards one on 
motherboard SIS620 AGP and a PCI Voodoo 3 generic.
Installation would fail every time no matter what I tried.
Was successful only after removing all X windows packages from install.
Then was successful on a complete reinstall when I chose not to configure X in 
the install process.

Still cannot get Fisher to see the voodoo card but that might be a bios thing.
Will try laptop with workaround as soon as time permits.
Comment 6 Need Real Name 2001-02-12 11:37:51 EST
Have just tried reinstall on laptop(Toshiba) and tried to just not configure X 
windows in install.
Same failure as original report.
Will try 2 things that worked on other system.
Will partition more megs to /boot (64 megs vs. 23) and try full install.
If that does not work will try to install without X windows then try to fully 
install. Both will be with 64meg /boot partition
Comment 7 Need Real Name 2001-02-12 11:58:18 EST
Just tried install with no X packages and raised /boot partition to 64 megs
Failed with same message as original.
Will not continue as I have no further ideas on how to work around.
Comment 8 Erik Troan 2001-02-21 10:17:27 EST
Are you trying to install a fresh system, or upgrade a system? How are you
booting (cd or floppy), and where are you installing from?
Comment 9 Need Real Name 2001-02-24 08:54:41 EST
Tried to install fresh system on laptop Toshiba 2105CDS
Laptop had RH 7.0 on it.

Laptop CD would not boot from Fisher CD
(have been able boot same CD on other computer)
Laptop CD does boot RH 7.0 from CD

Booted laptop with RH 7.0 floppy
then continued with CD.
Installation is ok until post install then failure message
Comment 10 Need Real Name 2001-02-24 09:01:23 EST
End of process leaves me with unusable system
on re-boot
I get  "LI" of LILO and  is unbootable
Comment 11 Erik Troan 2001-02-24 10:49:36 EST
Booting with 7.0 media will not work. You must use the boot disk that matches
the CDROM.

Have you tried booting the 7.1 boot floppy?
Comment 12 Michael Fulbright 2001-04-02 16:00:43 EDT
Closing due to inactivity - please reopen if you have anything to add to the bug
report.

Note You need to log in before you can comment on or make changes to this bug.