Bug 26804 - release notes dialog focus
Summary: release notes dialog focus
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard: Florence RC-1
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-09 09:12 UTC by Ed McKenzie
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-20 00:02:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed McKenzie 2001-02-09 09:12:30 UTC
The release notes dialog during install keeps focus, so that pressing enter
to the 'insert disc 2' popup just brings up/closes the relnotes window. Is
this by design?

Comment 1 Brent Fox 2001-02-14 08:46:57 UTC
No, this is a bug.  We're working on it.

Comment 2 Matt Wilson 2001-02-14 09:05:40 UTC
I applied the following.

--- gui.py	2001/02/14 07:40:15	1.181
+++ gui.py	2001/02/14 08:11:46
@@ -249,7 +249,8 @@
         label = hbox.children ()[1]
         label.set_line_wrap (TRUE)
         self.window.set_position (WIN_POS_CENTER)
-
+        win = self.window.get_window()
+        win.keyboard_grab(0)
         self.window.show_all ()

         threads_leave ()
@@ -268,10 +269,12 @@
             self.mutex = None
             threads_enter ()
             self.rc = self.window.run ()
+            win.keyboard_ungrab()
             threads_leave ()
         else:
             self.mutex = Event ()
             self.mutex.wait ()
+            win.keyboard_ungrab()

 class InstallInterface:
     def __init__ (self, runres, nofbmode):



Note You need to log in before you can comment on or make changes to this bug.