Bug 26813 - rpm -U portmap does not restores state
Summary: rpm -U portmap does not restores state
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: portmap   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Aaron Brown
URL:
Whiteboard: Florence RC-1
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-09 11:39 UTC by Enrico Scholz
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-09 23:08:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2001-02-09 11:39:05 UTC
The condrestart-rule from /etc/init.d/portmap (used by rpm-U ...) calls
directly the restart()-function without restoring the state (see
pmap_dump/pmap_set part some lines above).

I suggest to put the pmap_dump/pmap_set stuff into the restart()-function.


This bug is critical because important services like NFS or YP must be
registered by portmap and have to be restarted after upgrading portmap. See
#14612 also.

Comment 1 Trond Eivind Glomsrxd 2001-02-09 21:57:00 UTC
Seems like a very good idea.... I'll look into it.

Comment 2 Glen Foster 2001-02-09 23:07:57 UTC
This defect is considered MUST-FIX for Florence Release-Candidate #1

Comment 3 Trond Eivind Glomsrxd 2001-02-11 23:56:18 UTC
Done, in portmap-4.0-34.


Note You need to log in before you can comment on or make changes to this bug.