Bug 26846 - pump -l option not honored during renew
Summary: pump -l option not honored during renew
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pump   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-09 17:21 UTC by Anders Blomdell
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-28 16:14:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Anders Blomdell 2001-02-09 17:21:55 UTC
When giving the command 'pump -R -l <lease time>', the resulting
lease time is the one given when pump was first started. It would 
also be nice to be able to specify the desired lease time in 
/etc/sysconfig/network, perhaps after this small patch to ifup 
(dhcpd not properly handled):

--- /sbin/O.ifup        Thu Aug  3 16:21:32 2000
+++ /sbin/ifup  Fri Feb  9 17:16:41 2001
@@ -88,8 +88,14 @@
 fi
 
 if [ -n "${DYNCONFIG}" ]; then
+    . /etc/sysconfig/network
+
     PUMPARGS=
     DHCPCDARGS=
+
+    if [ -n "${DHCP_LEASE_TIME}" ]; then
+       PUMPARGS="-l ${DHCP_LEASE_TIME}"
+    fi
     if [ -n "${DHCP_HOSTNAME}" ]; then
        PUMPARGS="-h ${DHCP_HOSTNAME}"
        DHCPCDARGS="-h ${DHCP_HOSTNAME}"

Comment 1 Elliot Lee 2001-08-08 04:57:34 UTC
Can you set the lease time in /etc/pump.conf instead?

Comment 2 Anders Blomdell 2001-08-08 06:21:00 UTC
No I can't, since that (as far as I can tell from source and docs) is not 

supported. I also consider it a bug (albeit a minor one) that pump silently 

ignores the '-l <lease_time>' option during a manual renewal.




Note You need to log in before you can comment on or make changes to this bug.