Bug 26851 - Wrong gid in up2date when called as non-root
Summary: Wrong gid in up2date when called as non-root
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: usermode   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-09 19:19 UTC by Carlos Fernanez
Modified: 2015-01-07 23:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 11:31:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Carlos Fernanez 2001-02-09 19:19:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


When up2date is called from a non-root account (and after obviously 
providing the root password), up2date uses the group id from the non-root 
account, or so it seems. I'm assuming this because of the group owning the 
file in /var/spool/up2date.

Reproducible: Always
Steps to Reproduce:
1. up2date from a non-root account
2. skip some packages so they're left in /var/spool/up2date
3. ls /var/spool/2p2date
	

Actual Results:  I got
drwxr-xr-x   12 root     root         4096 Jan 15 08:35 ..
-rw-------    1 root     cfsmp3       7724 Jan 31 05:14 sysklogd-1.3.33-
8.i386.hdr
-rw-------    1 root     cfsmp3      28120 Jan 31 05:14 pam-0.72-
37.i386.hdr
drwxr-xr-x    2 root     root         4096 Jan 31 07:09 .


Expected Results:  drwxr-xr-x   12 root     root         4096 Jan 15 
08:35 ..
-rw-------    1 root     root         7724 Jan 31 05:14 sysklogd-1.3.33-
8.i386.hdr
-rw-------    1 root     root        28120 Jan 31 05:14 pam-0.72-
37.i386.hdr
drwxr-xr-x    2 root     root         4096 Jan 31 07:09 .

Comment 1 Cristian Gafton 2001-02-20 01:34:11 UTC
Assigned QA to jturner

Comment 2 Preston Brown 2001-02-20 18:07:55 UTC
this was a usermode issue, fixed in rawhide.


Note You need to log in before you can comment on or make changes to this bug.