Bug 26865 - rtl 8139 does not work
Summary: rtl 8139 does not work
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i686
OS: Linux
high
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard: Florence Gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-09 21:22 UTC by Mikael Johansson
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-02 20:38:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mikael Johansson 2001-02-09 21:22:50 UTC
My network card (rtl 8138B) does not work with the new kernel 2.4. I have
tried to compile my own version of 2.4.0 on rh7.0 and i have installed
rh7.1beta with kernel 2.4.0-0.99.11. The card works on rh 7.0 with the
kernel that follows that dist.

Comment 1 Glen Foster 2001-02-09 23:16:09 UTC
We (Red Hat) should really try to resolve this before next release.

Comment 2 Bill Nottingham 2001-02-10 00:19:22 UTC
What driver are you using?

Comment 3 Arjan van de Ven 2001-02-12 12:14:56 UTC
If you upgrade your kernel to the newer one in Rawhide, does it still not work?

Comment 4 Arjan van de Ven 2001-02-12 12:15:29 UTC
If you upgrade your kernel to the newer one in Rawhide, does it still not work?

Comment 5 Mikael Johansson 2001-02-17 17:06:41 UTC
No it does not work on the Rawhide kernel (2.4.0-0.99.23) either. I use the
driver rtl8139.

Comment 6 Bill Nottingham 2001-02-19 02:43:12 UTC
Um, there isn't a rtl8139 driver in 2.4; this could be the cause
of your problem. :)   Use the 8139too driver instead.

Comment 7 Michael K. Johnson 2001-03-01 03:36:29 UTC
We are hearing success reports both with the wolverine kernel
and the kernel in rawhide, 2.4.1-0.1.14.  Please let us know
if those kernels, especially the rawhide kernel, still has this
problem for you.

Comment 8 Mikael Johansson 2001-03-02 20:37:59 UTC
Ok it works with the driver 8139too. I have tested to do a reinstall and it work
fine. This must be documented and implemented in the new RH dist so it changes
the driver automatically when upgrading an old system. Otherwise alot of people
with this card is gonna get problems.

Comment 9 Erik Troan 2001-03-03 15:06:20 UTC
Wolverine upgrades migrate this driver automatically.


Note You need to log in before you can comment on or make changes to this bug.