Bug 26890 - Rpm crashes when it tries to install nmh.
Rpm crashes when it tries to install nmh.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i586 Linux
medium Severity low
: ---
: ---
Assigned To: Michael K. Johnson
David Lawrence
http://www.devuurmuur.com/~sjoerd/bug...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-09 17:30 EST by s.langkemper
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-14 11:40:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description s.langkemper 2001-02-09 17:30:17 EST
I am running RedHat 7.0 and I tried to install (rpm -F n*.rpm) the nmh package from the RedHat Fisher beta CD-ROM. RPM crashes with "Unable to handle kernel paging request...".

You can view the error message on http://www.devuurmuur.com/~sjoerd/bug.txt, which shows a screendump.
Comment 1 Jeff Johnson 2001-02-13 13:44:59 EST
This is a kernel problem, changing component.
Comment 2 Michael K. Johnson 2001-02-13 20:01:10 EST
Text pasted from the URL cited above:

Unable to handle kernel paging request at virtual address 000012a8
 printing eip:
c0120c95
*pde = 00000000
Oops: 0002
CPU:    0
EIP:    0010:[<c0120c95>]
EFLAGS: 00010286
eax: c12906c4   ebx: c10012ec   ecx: 00000087   edx: 000012a8
esi: c10012ec   edi: c1001308   ebp: 0000013a   esp: c236fec8
ds: 0018   es: 0018   ss: 0018
Process rpm (pid: 3313, stackpage=c236f000)
Stack: c10406c4 c0127a86 c10012ec c0250f60 c02511f4 00000002 00000001 c012950a
       c0250f60 00000001 c02511f8 00000000 00000005 c012966f c02511ec 00000000
       00000002 00000001 00000001 c02511ec 00000000 c10ed200 00000000 fffffff4
Call Trace: [<c0127a86>] [<c012950a>] [<c012966f>] [<c0123e64>] [<c012e216>] [<c
0115e3a>] [<c0108ee3>]

Code: 89 02 8b 43 10 8b 53 34 c7 43 08 00 00 00 00 85 c0 74 03 89
Segmentation fault

Please run that trace through ksymoops on your machine and
report the output (the numbers are specific to the kernel you
are running).  So on your machine, running that kernel, do
cat /some/file/containing/that/trace | ksymoops
and then paste the output here.
Comment 3 s.langkemper 2001-02-14 11:40:02 EST
ksymoops 2.3.4 on i586 2.4.0.  Options used
     -v /usr/src/linux/vmlinux (specified)
     -k /proc/ksyms (default)
     -l /proc/modules (default)
     -o /lib/modules/2.4.0/ (default)
     -m /usr/src/linux/System.map (default) c0120c95
*pde = 00000000
Oops: 0002
CPU:    0
EIP:    0010:[<c0120c95>]
Using defaults from ksymoops -t elf32-i386 -a i386
EFLAGS: 00010286
eax: c12906c4   ebx: c10012ec   ecx: 00000087   edx: 000012a8
esi: c10012ec   edi: c1001308   ebp: 0000013a   esp: c236fec8
ds: 0018   es: 0018   ss: 0018
Process rpm (pid: 3313, stackpage=c236f000)
Stack: c10406c4 c0127a86 c10012ec c0250f60 c02511f4 00000002 00000001 c012950a
       c0250f60 00000001 c02511f8 00000000 00000005 c012966f c02511ec 00000000
       00000002 00000001 00000001 c02511ec 00000000 c10ed200 00000000 fffffff4
Call Trace: [<c0127a86>] [<c012950a>] [<c012966f>] [<c0123e64>] [<c012e216>] [<c
0115e3a>] [<c0108ee3>]
Code: 89 02 8b 43 10 8b 53 34 c7 43 08 00 00 00 00 85 c0 74 03 89 >>EIP; c0120c95 <__remove_inode_page+35/70>   <=====
Trace; c0127a86 <reclaim_page+336/430>
Trace; c012950a <__alloc_pages_limit+7a/b0>
Trace; c012966f <__alloc_pages+12f/300>
Trace; c0123e64 <generic_file_write+294/480>
Trace; c012e216 <sys_write+96/d0>
Code;  c0120c95 <__remove_inode_page+35/70>
00000000 <_EIP>:
Code;  c0120c95 <__remove_inode_page+35/70>   <=====
   0:   89 02                     mov    %eax,(%edx)   <=====
Code;  c0120c97 <__remove_inode_page+37/70>
   2:   8b 43 10                  mov    0x10(%ebx),%eax
Code;  c0120c9a <__remove_inode_page+3a/70>
   5:   8b 53 34                  mov    0x34(%ebx),%edx
Code;  c0120c9d <__remove_inode_page+3d/70>
   8:   c7 43 08 00 00 00 00      movl   $0x0,0x8(%ebx)
Code;  c0120ca4 <__remove_inode_page+44/70>
   f:   85 c0                     test   %eax,%eax
Code;  c0120ca6 <__remove_inode_page+46/70>
  11:   74 03                     je     16 <_EIP+0x16> c0120cab <__remove_inode_page+4b/70>
Code;  c0120ca8 <__remove_inode_page+48/70>
  13:   89 00                     mov    %eax,(%eax)
Comment 4 Michael K. Johnson 2001-02-14 12:18:11 EST
Aha, you are running a 2.4.0 kernel.  I don't know which
one (rpm -q kernel?  uname -a?) but this looks like VM
problems that have been fixed in more recent kernels.

Note You need to log in before you can comment on or make changes to this bug.