This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 26892 - Wrong video mode on reboot with Rage Mobility
Wrong video mode on reboot with Rage Mobility
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-09 18:13 EST by Aaron Brown
Modified: 2007-04-18 12:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-01 10:49:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Aaron Brown 2001-02-09 18:13:39 EST
During a GUI installation (NFS-Full, FTP-Full, HTTP-Laptop), I chose
1024x768x16 for my display settings.  Upon reboot, the system was set to
640x480x16.

This problem doesn't exhibit itself after a TUI installation.  Also, during
"test settings" the correct resolution is diplayed.
Comment 1 Aaron Brown 2001-02-09 18:27:25 EST
I meant...
GUI: NFS-Full
TUI: FTP-Full, HTTP-Laptop

Also, I tried this with qa0207-qa209.

Comment 2 Glen Foster 2001-02-12 18:00:30 EST
This defect is considered MUST-FIX for Florence Release-Candidate #1
Comment 3 Brent Fox 2001-02-14 04:09:49 EST
Is the XF86Config file right and the resolution just comes up wrong, or is the
file incorrect?
Comment 4 Aaron Brown 2001-02-14 05:03:24 EST
Brent, here's what I've found:

Even though I picked everything correctly during the install, a post install
check of XF86Config shows:

"800x600", "Generic Monitor".  (I was wrong about 640x480, just looked like it.
Sorry)

When I manually change it to "1024x768", "Generic Laptop Display 1024x768", it
works like a champ.
Comment 5 Matt Wilson 2001-02-14 09:25:10 EST
so user error - picked wrong LCD screen setting.
Comment 6 Aaron Brown 2001-02-15 17:57:02 EST
Re-opening, per Matt's recommendation.
Still not working.  In my above comment, when I say "manually change", I mean
"running Xconfigurator" from the shell as root.

Comment 7 Aaron Brown 2001-02-16 02:07:22 EST
Tried inserting "linux vga-787" at bootup.  Didn't have any effect.
Comment 8 Brent Fox 2001-02-16 15:30:34 EST
Interestingly, this does not happen in TUI mode.  Also, testing X at 1024x768
results in a correct file written to /tmp/XF86Config.test during the install.
After package installation, however, the wrong settings are written to the
/mnt/sysimage/etc/X11/XF86Config-4 file.  This doesn't make much sense.
Comment 9 David Sainty 2001-02-17 17:53:08 EST
I presume the mobility is on a notebook with built-in LCD.  What is the model of
notebook? Can you give any more information, e.g. ddcprobe output, or the
original XF86Config-4 file that's written to the disk?

I have access to several notebooks with mobility chipsets, but I do not believe
I have seen the bebaviour where you select 1024x768, but "800x600" is actually
set in the XF86Config-4 file...


DS..
Comment 10 Brent Fox 2001-02-20 12:10:04 EST
I've seen it happen on a Compaq Presario 1700T and Aaron's is a Dell Latitude
CPx.  Both have the ATI Rage Mobility with 8MB of vram.
Comment 11 Brent Fox 2001-03-01 00:35:22 EST
This problem is due to a bug in iw/xconfig.py.  I have a fix for it, but I'm
waiting for permission to check it into CVS.
Comment 12 Brent Fox 2001-03-01 11:39:00 EST
The update has now been committed to cvs.  Brock, this is a large change to the
code, so if you have time to double check me here, it would be appreciated.
I'll be testing this today as well.  The change affects the x configuration
screen in general, not just the Rage Mobility.  It just so happens that this
video card exposed a bug in xconfig.py that had been there for a while.

Note You need to log in before you can comment on or make changes to this bug.