Bug 26898 - Need to exclude additional users, missing man page
Summary: Need to exclude additional users, missing man page
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-10 00:28 UTC by Chris Ricker
Modified: 2007-03-27 03:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-20 15:21:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Ricker 2001-02-10 00:28:47 UTC
GDM has an optional browser of user accounts which can log in.  Normally, 
it should be configured so that system accounts (bin, uucp, etc.) don't 
show up in the browser.  As shipped, some but not all system accounts are 
disabled.  I had to at least add pvm, postgres, mysql, and gdm to the 
Excludes line in /etc/X11/gdm/gdm.conf, and there may be others which 
should also be excluded.

gdm-2.0beta2-39

Comment 1 Glen Foster 2001-02-12 23:10:33 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 2 Tim Powers 2001-02-13 23:34:33 UTC
Thanks for letting us know about this. It is fixed in the rawhide package.
Here's the Exclude line in there now (wrapped for sane reading):

Exclude=bin,daemon,adm,lp,sync,shutdown,halt,mail,news,uucp,operator,nobody,
games,gopher,ftp,nscd,mailnull,ident,rpc,rpcuser,xfs,gdm,postgres,apache,
named,mysql,ldap,pvm,squid

Tim

Comment 3 Chris Ricker 2001-03-04 18:39:16 UTC
I'm re-opening this and transferring it to kdm since in RC2 kdm has the same
problem.  I'm seeing:

apache
gdm
halt
ident
mailnull
named
nscd
postgres
rpc
rpcuser
shutdown
sync
xfs

as well as the real user accounts.

Long-term, you should probably just add a file in /etc that lists system
accounts, and have rpms add to that list as they install, since you're now
getting into multiple packages which need to know that information....

I'm not sure how to configure kdm not to list these users.  It doesn't have a
man page, which is also a bug.

Comment 4 Tim Powers 2001-03-20 14:40:32 UTC
I'm assigning this to Bero so that he knows about it (I don't think he does
since it's currently assigned to Havoc.

Tim

Comment 5 Tim Waugh 2001-03-20 15:11:31 UTC
Is this a duplicate of bug #23136 now?


Comment 6 Bernhard Rosenkraenzer 2001-03-20 15:19:43 UTC
Yes.


*** This bug has been marked as a duplicate of 23136 ***

Comment 7 Chris Ricker 2001-03-20 15:21:23 UTC
No.  There's still the other bug, that absolutely no documentation for kdm is
installed.

Comment 8 Bernhard Rosenkraenzer 2001-03-21 20:18:00 UTC
You aren't looking in the right place.
Point your Konqueror at
file:/usr/share/doc/HTML/default/kdm/index.html



Note You need to log in before you can comment on or make changes to this bug.