Bug 26900 - IBM PCMCIA token ring card on thinkpad 600 doesn not work since upgrade from RedHat Linux 6.2 to 7.0
Summary: IBM PCMCIA token ring card on thinkpad 600 doesn not work since upgrade from ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-10 00:34 UTC by Hermann huebler
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-20 18:13:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hermann huebler 2001-02-10 00:34:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows 98; 
1012SurfnetVersion2.0)

** I'm not sure if the Component is correct - actually it's a problem with 
the PCMCIA card - but I did not find a pcmcia component. I set the 
priority and the severity to high because I have to go back to the 
previous system if I don't get the card running - Thanks! **

I was runnning RedHat Linux 6.2 on an IBM Thinkpad 600 with an  PCMCIA IBM 
Token Ring card installed. The configuration used on RedHat 6.2 was simply 
the default /etc/pcmcia/config.opts with the module for ibmtr_cs 
activated. 

Since I upgraded from Redhat 6.2 to 7.0 (it does not mind if you run a 
scratch installation or an upgrade installation)the PCMCIA IBM Token Ring 
card does not work any more - I also tried differenct mmiobase and 
srambase settings. I get the following error messages when pcmcia is 
started in RedHat 7.0 in the /var/logs/messages:

=================
Feb 10 00:03:30 localhost kernel: unloading PCMCIA Card Services
Feb 10 00:03:30 localhost kernel: Linux PCMCIA Card Services 3.1.19
Feb 10 00:03:30 localhost kernel:   kernel build: 2.2.16-22 #1 Tue Aug 22 
16:49:06 EDT 2000
Feb 10 00:03:30 localhost kernel:   options:  [pci] [cardbus] [apm]
Feb 10 00:03:30 localhost kernel: PCI routing table version 1.0 at 0xf9e10
Feb 10 00:03:30 localhost kernel: Intel PCIC probe: 
Feb 10 00:03:30 localhost kernel:   TI 1250A rev 02 PCI-to-CardBus at slot 
00:02, mem 0x20301000
Feb 10 00:03:30 localhost kernel:     host opts [0]: [ring] [isa irq] [pci 
irq 11] [lat 168/176] [bus 1/3]
Feb 10 00:03:30 localhost kernel:     host opts [1]: [ring] [isa irq] [pci 
irq 11] [lat 168/176] [bus 4/6]
Feb 10 00:03:30 localhost kernel:     ISA irqs (scanned) = 3,4,7,9,10 PCI 
status changes
Feb 10 00:03:30 localhost cardmgr[7335]: starting, version is 3.1.19
Feb 10 00:03:30 localhost cardmgr[7335]: watching 2 sockets
Feb 10 00:03:30 localhost kernel: cs: IO port probe 0x1000-0x17ff: 
excluding 0x15e8-0x15ef
Feb 10 00:03:30 localhost kernel: cs: IO port probe 0x0100-0x04ff: 
excluding 0x130-0x137 0x200-0x207 0x220-0x22f 0x388-0x38f 0x3b8-0x3df 
0x4d0-0x4d7
Feb 10 00:03:30 localhost kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Feb 10 00:03:31 localhost cardmgr[7335]: initializing socket 1
Feb 10 00:03:31 localhost kernel: cs: memory probe 0xa0000000-0xa0ffffff: 
clean.
Feb 10 00:03:31 localhost cardmgr[7335]: socket 1: IBM Token Ring Adapter
Feb 10 00:03:31 localhost cardmgr[7335]: executing: 'modprobe ibmtr_cs 
mmiobase=0xd0000 srambase=0xd4000'
Feb 10 00:03:31 localhost kernel: ibmtr_cs: register_trdev() failed
Feb 10 00:03:31 localhost kernel: tr0: Unexpected interrupt from tr adapter
Feb 10 00:03:31 localhost cardmgr[7335]: get dev info on socket 1 failed: 
No such device
=================


Reproducible: Always
Steps to Reproduce:
1.Install RedHat 7.0 on a ThinPad 600 with a IBM PCMCIA Token Ring Adapter
2.
3.
	

Actual Results:  The PC can't connect to the token ring LAN ..... so no 
cennection is possible.

Expected Results:  The PC should be able to connect to the token ring

To compare here are the /var/log/messges lines from the Redhat 6.2 system:

====== RedHat 6.2 /var/log/messages =======
Feb  9 21:12:24 localhost kernel: unloading PCMCIA Card Services 
Feb  9 21:12:24 localhost kernel: Linux PCMCIA Card Services 3.1.8 
Feb  9 21:12:24 localhost kernel:   kernel build: 2.2.14-5.0 #1 Tue Mar 7 
21:07:39 EST 2000 
Feb  9 21:12:24 localhost kernel:   options:  [pci] [cardbus] [apm] 
Feb  9 21:12:24 localhost kernel: Intel PCIC probe:  
Feb  9 21:12:24 localhost kernel:   TI 1250A PCI-to-CardBus at bus 0 slot 
2, mem 0x20301000, 2 sockets 
Feb  9 21:12:24 localhost kernel:     host opts [0]: [ring] [pwr save] 
[isa irq] [no pci irq] [lat 168/176] [bus 1/3] 
Feb  9 21:12:24 localhost kernel:     host opts [1]: [ring] [pwr save] 
[isa irq] [no pci irq] [lat 168/176] [bus 4/6] 
Feb  9 21:12:24 localhost kernel:     ISA irqs (scanned) = 3,4,7,9,10 
polling interval = 1000 ms 
Feb  9 21:12:24 localhost cardmgr[691]: starting, version is 3.1.8
Feb  9 21:12:24 localhost cardmgr[691]: watching 2 sockets
Feb  9 21:12:24 localhost kernel: cs: IO port probe 0x1000-0x17ff: 
excluding 0x15e8-0x15ef 
Feb  9 21:12:24 localhost kernel: cs: IO port probe 0x0100-0x04ff: 
excluding 0x130-0x137 0x200-0x207 0x220-0x22f 0x388-0x38f 0x3b8-0x3df 
0x4d0-0x4d7 
Feb  9 21:12:24 localhost kernel: cs: IO port probe 0x0a00-0x0aff: clean. 
Feb  9 21:12:24 localhost cardmgr[691]: initializing socket 1
Feb  9 21:12:24 localhost kernel: cs: memory probe 0xa0000000-0xa0ffffff: 
clean. 
Feb  9 21:12:24 localhost cardmgr[691]: socket 1: IBM Token Ring Adapter
Feb  9 21:12:25 localhost cardmgr[691]: 
executing: 'insmod /lib/modules/2.2.14-5.0/pcmcia/ibmtr_cs.o 
mmiobase=0xd0000 srambase=0xd4000'
Feb  9 21:12:25 localhost kernel: ibmtr.c: v1.3.57   8/ 7/94 Peter De 
Schrijver and Mark Swanson 
Feb  9 21:12:25 localhost kernel:          v2.1.125 10/20/98 Paul Norton 
<pnorton@ieee.org> 
Feb  9 21:12:25 localhost kernel:          v2.2.0   12/30/98 Joel Sloan 
<jjs@c-me.com> 
Feb  9 21:12:25 localhost kernel: tr1: ISA 16/4 Adapter/A (short) | 16/4 
ISA-16 Adapter found 
Feb  9 21:12:25 localhost kernel: tr1: using irq 0, PIOaddr a20, 16K 
shared RAM. 
Feb  9 21:12:25 localhost kernel: tr1: Hardware address : 
08:00:5A:E4:98:8B 
Feb  9 21:12:25 localhost kernel: tr1: Maximum MTU 16Mbps: 4056, 4Mbps: 
4568 
Feb  9 21:12:25 localhost kernel: tr1: port 0xa20, irq 3, mmio 0xd0000, 
sram 0xd4000, 
Feb  9 21:12:25 localhost kernel:   hwaddr=08005AE4988B 
Feb  9 21:12:25 localhost cardmgr[691]: executing: './network start tr0'
Feb  9 21:12:25 localhost cardmgr[691]: + usage: ifup <device name>
Feb  9 21:12:25 localhost cardmgr[691]: start cmd exited with status 1
Feb  9 21:12:27 localhost kernel: tr1: Initial interrupt : 16 Mbps, shared 
RAM base 000d4000. 
Feb  9 21:12:46 localhost kernel: tr1: Adapter initialized and opened. 
=========================

The excert of the RedHat 7.0 /var/log/messages is already pasted into the 
problem description

Comment 1 Hermann huebler 2001-09-20 18:13:04 UTC
Problem seems to be fixed by RedHat 7.1. With this version I was unable to
recreate the problem.

Comment 2 Michael K. Johnson 2001-09-20 20:13:35 UTC
Thanks for letting us know.


Note You need to log in before you can comment on or make changes to this bug.