Bug 26905 - apm seems to put monitor to sleep frequently.
apm seems to put monitor to sleep frequently.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-09 21:01 EST by adam.huffman
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-15 18:56:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description adam.huffman 2001-02-09 21:01:50 EST
XF86Config-4 as created during installation had the DPMS option.

Subsequently I had an intermittent problem with the monitor going to sleep
every few seconds, even though I kept pressing a key to get the screen back
again.

The problem has not recurred since I commented that option.

GeForce2 GTS card, Iiyama VisionMaster MF-8617E monitor, Abit KAy-100 m/b
Comment 1 adam.huffman 2001-02-11 19:11:38 EST
The problem has actually come back, even though I still have the DPMS option commented out.  This may be something to do with the ACPI problems in 2.4.

When it started happening today I got the following message several times in the log: (WW) Cannot open APM
Comment 2 Glen Foster 2001-02-12 18:13:55 EST
We (Red Hat) should really try to resolve this before next release.
Comment 3 Mike A. Harris 2001-02-13 19:28:07 EST
NVidia cards are proprietary.  As such there are no specifications available
with which to understand how their cards work without signing an NDA.

Doing so would exclude any fixes from being included in the official open
source.  As such, if this problem is caused by the nvidia driver all I can
do is send it upstream.

Not what you want to hear but... ATI Radeon cards are very well supported in
contrast.  Worth it to upgrade, but obviously that doesn't help if you can't
afford it.  Just a suggestion.
Comment 4 adam.huffman 2001-02-13 19:43:21 EST
I understand what you're saying, but I should point out that this problem occurs
with the 'nv' driver, which is written and maintained by the XFree86 team, not
NVidia's 'nvidia' binary driver.  Whilst I did install the nvidia driver in 7.0,
I haven't done so yet in Fisher.
Comment 5 Mike A. Harris 2001-02-15 02:50:34 EST
Sorry, but I was in fact refering to the nv driver as supplied by the
XFree86 team.  It is undocumented whichever driver you're using.
This must be a glitch in APM or ACPI as you postulated..  Reassigning
to apmd package with hopes someone at meridian handling apm can look into
this with the right hardware.
Comment 6 Bernhard Rosenkraenzer 2001-03-06 14:37:34 EST
This has nothing whatsoever to do with apmd (which is just responsible for 
suspend/resume).
If it's an ACPI problem, it's a kernel problem - but I'd rather think it's an 
XFree86 problem (DPMS). Does this happen in text mode?

Comment 7 Arjan van de Ven 2001-03-06 14:50:30 EST
Our kernel doesn't use ACPI anymore.
Must be an X problem
Comment 8 adam.huffman 2001-03-15 18:56:25 EST
This problem hasn't occurred in Wolverine at all.
Comment 9 Mike A. Harris 2001-04-02 11:45:05 EDT
Closing bug, submitter indicates it is fixed now...
Comment 10 adam.huffman 2001-04-02 19:01:23 EDT
This just started happening again tonight, but I think it is actually caused
by xscreensaver.  I've killed the xscreensaver process and it seems to have
stopped.

Note You need to log in before you can comment on or make changes to this bug.