Bug 26914 - Inconsistencies and mispellings in Spanish language choices
Summary: Inconsistencies and mispellings in Spanish language choices
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 7.1
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Matt Wilson
QA Contact: Brock Organ
URL:
Whiteboard: Florence Gold
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-10 04:35 UTC by Nitebirdz (Jesus Ortega)
Modified: 2005-10-31 22:00 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2001-02-27 02:30:47 UTC


Attachments (Terms of Use)

Description Nitebirdz (Jesus Ortega) 2001-02-10 04:35:49 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.2.14-5.0 i686)


Section: "Choose the languages to be installed"

Problems:

1) Ecuador is incorrectly spelt.  It should be "Ecuador", and not
"Equador".

2) There is no choice for Spain, as in the case of Great Britain
["English(Great Britain)"].  Sort of confusing.  User may spend a while
looking for the correct choice.  The correct choice could be simply
"Spanish", but if that's the case it's inconsistent with the way the
choices for English were laid out.

3) "Spanish(USA)"?  Not positive what this choice is all about, but do you
truly have translations into Spanglish.  

Reproducible: Always
Steps to Reproduce:
1.  Simply run the anaconda installer in text mode.  I assume the same
applies to the other modes too, but didn't test it.

Comment 1 Glen Foster 2001-02-12 23:13:59 UTC
We (Red Hat) should really try to resolve this before next release.

Comment 2 Preston Brown 2001-02-26 20:05:48 UTC
Jakub:

For this user's problem #1, file /usr/share/i18n/locales/es_EC needs to be
modified and the Equador --> Ecuador change made.

#2 is an anaconda issue; we are currently masking Spanish(Spain) and assuming
that it should be the default.  We don't do this for english because it is so
widespread.  You could argue that  Spanish is the same way. If that is the case,
maybe the change would be warranted, I don't think we are going to do it for the
next release however.

#3, yes, glibc does support a Spanish in the USA setting as a valid locale.

Comment 3 Jakub Jelinek 2001-02-26 21:50:13 UTC
1) is not a bug - both
_NL_IDENTIFICATION_LANGUAGE and _NL_IDENTIFICATION_TERRITORY
are specified in english for all locales
2) is anaconda issue, reassigning to anaconda
3) is not a bug - es_US is supported

Comment 4 Matt Wilson 2001-03-07 19:18:59 UTC
fixed 2) in CVS.



Note You need to log in before you can comment on or make changes to this bug.