Bug 269861 - autofs NFS4 mount expiry causes NFS4 server to complain
autofs NFS4 mount expiry causes NFS4 server to complain
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
7
All All
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-30 19:02 EDT by David Carlson
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-31 00:21:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Carlson 2007-08-30 19:02:08 EDT
Description of problem:
Automount of NFS4 export, when expires and unmounts, attempts to unmount the
mount with NFS3 or other strange behavior.  This did not happen on older autofs
versions and does not happen with a manual mount and unmount of the exact same
options.

the end result is a lot of:
Aug 30 17:52:45 blue mountd[2535]: refused unmount request from red for / (/):
not exported

in blue's logs

Version-Release number of selected component (if applicable):
5.0.1-25

How reproducible:

- Have a NFS4 server with a root export
- automount map on client is simply:
*       -fstype=nfs4,rw         &:/

Steps to Reproduce:
1. Set up /nfs4/blue (on red) to be an NFS4 automount to blue:/
2. use the above mount, and wait for it to expire
3. notice:


Actual results:
System silently unmounts NFS4 mount

Expected results:
Aug 30 17:52:45 blue mountd[2535]: refused unmount request from red for / (/):
not exported

Additional info:
Comment 1 David Carlson 2007-08-30 19:37:16 EDT
FYI: still does it on -26
Comment 2 Ian Kent 2007-08-30 23:23:53 EDT
I'm a little unsure of what you mean here.

If /etc/exprots on <server> contains:
/export2   (rw,fsid=0,subtree_check)

and I do:
mount -t nfs4 <server>:/ /mnt/tmp

The nfs4 export /expeot2 is mounted as <server>:/ on
/mnt/tmp as it should be.

If I then do
umount /mnt/tmp
the export is umounted as it should be.

Can you help me by explaining what the problem is?

Ian
Comment 3 Ian Kent 2007-08-30 23:33:14 EDT
(In reply to comment #0)
> 
> the end result is a lot of:
> Aug 30 17:52:45 blue mountd[2535]: refused unmount request from red for / (/):
> not exported

OK, I see these on my server.

> 
> Actual results:
> System silently unmounts NFS4 mount

OK, as it should.

> 
> Expected results:
> Aug 30 17:52:45 blue mountd[2535]: refused unmount request from red for / (/):
> not exported

And we get those on the server for manual or automounted
umounts and you say that's expected?

Ian
Comment 4 David Carlson 2007-08-30 23:42:38 EDT
Crap, my expected and actual results were swapped.  We expect a clean unmount
but we get that warning on the server.

If I make a manual mount and unmount it, I don't get the error in the server
logs, but when I use the automount I do get the error.  

I run a cron job every 5 minutes that ends up mounting that mount (because I'm
sane, honest), so every 5 minutes plus 90 seconds give or take, I get that error
message in the server's log.

Comment 5 David Carlson 2007-08-31 00:12:08 EDT
The messages on the server start _exactly_ when I rebooted into autofs -23 on
the client machine.

I am able to force this behavior in a manual sense by doing:

mount -t nfs4 blue:/ /tmp/blue
umount -t nfs /tmp/blue

then immediately, this gets logged:
Aug 30 23:11:01 blue mountd[2535]: refused unmount request from red for / (/):
not exported
Comment 6 David Carlson 2007-08-31 00:21:31 EDT
then twenty seconds later I realize that:


mount -t nfs4 blue:/ /tmp/blue
umount -t nfs4 /tmp/blue

also does it.  so the problem is with mount.nfs.  sorry to bother!

Note You need to log in before you can comment on or make changes to this bug.