Bug 270341 - ntpd starts before networkmanager finishes setting up.
ntpd starts before networkmanager finishes setting up.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
7
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-31 02:23 EDT by charles harris
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 11:20:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description charles harris 2007-08-31 02:23:56 EDT
Description of problem:
On boot, ntpd starts up before networkmanager finishes bringing up the network,
about 2 seconds early in fact, hence fails to find any time servers.

My workaround was to use S99ntpd in the level 5 startup and add a five second
sleep in the ntpd startup script. With these changes ntpd finds the servers, but
I'm sure there is a cleaner way to solve this problem.


Version-Release number of selected component (if applicable):
ntp-4.2.4p2-3.fc7

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Miroslav Lichvar 2007-08-31 04:34:53 EDT
ntpd should be able to use the new interface after a while (the default
interface update is 5 minutes). Have the servers specified in ntp.conf option
"dynamic"?
Comment 2 charles harris 2007-08-31 10:38:14 EDT
No, there is no "dynamic" option, ntp.conf is the standard Fedora version. The
problem was compounded by the fact that the default clocksource (tsc) drifted so
badly that ntpd never synchronized, so together with the initial failure to set
the clock, and resetting the hwclock on shutdown, I ended up with accumulated
errors of as much as 45 minutes -- rather unsettling. And no headsup message
either except grepping through the log.
Comment 3 Miroslav Lichvar 2007-08-31 13:12:22 EDT
For dynamic interfaces it's necessary to use the option. Default ntp.conf from
the package does that.
Comment 4 charles harris 2007-08-31 13:27:14 EDT
Hmm, I grepped dynamic in ntp.conf and didn't see it. I'll take a closer look
when I get back home as maybe it is under a different name. The install was from
the f7 live disk, is it possible that it differed from the full install?
Comment 5 Miroslav Lichvar 2007-08-31 14:07:37 EDT
system-config-date could overwrite the file, it doesn't support the option yet.
(bug #229217)
Comment 6 charles harris 2007-08-31 19:38:07 EDT
That must be it, because I don't see it. I wonder if ntpd will still synchronize
the system clock before starting if it finds the servers later?
Comment 7 Miroslav Lichvar 2007-09-03 08:29:53 EDT
The initial synchronization done by ntpdate? It's not delayed, so it will not do
any synchronization in this case.
Comment 8 Miroslav Lichvar 2007-09-12 11:03:18 EDT
Does ntpd work correctly when "dynamic" is used?
Comment 9 charles harris 2007-09-12 21:20:53 EDT
Yes, that seems to do the trick, ntpd came up about 30 seconds after the
network. Now let's see what happens if I fiddle with the clock... Sure enough,
the dynamic option went away.
Comment 10 Miroslav Lichvar 2007-09-17 11:20:16 EDT
Ok, I'm closing this as NOTABUG.

Note You need to log in before you can comment on or make changes to this bug.