Bug 27050 - XFree crash with Matrox millenium (mga2064w)
XFree crash with Matrox millenium (mga2064w)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
low Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-11 09:07 EST by Emmanuel Galanos
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-09 11:13:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Emmanuel Galanos 2001-02-11 09:07:27 EST
Easily reproducible, X will crash randomly within minutes of use.
Never had X crash with 3.3 server.
Comment 1 Mike A. Harris 2001-02-12 01:27:03 EST
Try disabling DRI.  If that doesn't fix it, try the latest release
in RAWHIDE, and let me know if it works for you.  There is new mga
patch in the rawhide version.
Comment 2 Glen Foster 2001-02-12 18:14:21 EST
We (Red Hat) should really try to resolve this before next release.
Comment 3 Emmanuel Galanos 2001-02-13 07:28:34 EST
Removing DRI now just makes X exit cleanly when I try and start something
like Konqueror from GNOME, rather than taking the console with it. Will try
the rawhide RPM of XFree-4. Firing up rsync now...
Comment 4 Emmanuel Galanos 2001-02-14 02:02:20 EST
Rawhide RPM XFree86-4.0.2-7 did not fix the problem.
ltracing the X server I can see a SIGSEGV being received.
I will rebuild the RPM with -g and fix soon.
Comment 5 Emmanuel Galanos 2001-02-15 02:41:39 EST
Ok. One of the bugs I am seeing seems to be in:

/xc/programs/Xserver/render/glyph.c

function ResizeGlyphHash

line oldSize = hash->hashSet->size;

(assuming I got all the debugging stuff correct).
I think there may also be another bug which causes the machine to hang
when DRI is enabled.. I will attempt to fix the code later if I have time..
so much other stuff to do in the meantime...
Comment 6 Emmanuel Galanos 2001-02-26 07:08:09 EST
I have installed XFree86 and xfs from wolverine onto my fisher
install. X is still really *really* unstable. Reproducible crash
by starting konqueror while in GNOME, and reproducible random crashes
within minutes of use of something like mozilla. I suppose I will
have to spend some time debugging the code once I receive the SRPMS
in the mail...(being on a 28.8k link is not fun)
Comment 7 Bill Nottingham 2001-02-28 15:20:43 EST
Does the XFree86-3.3.6 server work for you OK?
Comment 8 Bill Nottingham 2001-02-28 15:22:37 EST
This is fixed as of Xconfigurator-4.9.12-1, by using the 3.3.6 server
for older MGA cards.
Comment 9 Emmanuel Galanos 2001-03-01 07:48:55 EST
The 3.3.6 X server  fixes the reproducible crash with Konqueror but does not stop the
reproducible random crashes.
Comment 10 Preston Brown 2001-03-01 09:14:48 EST
Dave:

Can you heavily exercise a Millenium card and see if you can locally reproduce?
Comment 11 Need Real Name 2001-05-04 10:27:44 EDT
While running a Matrox g450 X will actually crash and reboot the machine.
I switched to a Matrox g400 and X just crashes without rebooting the machine
X also crashes with a G200
Comment 12 Mike A. Harris 2001-07-02 21:20:40 EDT
Can you try disabling the Render extension in your config, and see if that
makes the problem go away?  You'll also have to disable anti-aliased fonts
in KDE if using them.  If that makes it go away, it will help lead to a
quicker solution.
Comment 13 Alexei Podtelezhnikov 2001-07-03 01:13:03 EDT
I have never seen XFree86-4.0.3-[>5] random crashes on g200 and g400 (with or 
without DRI or anti-aliased fonts). I always use 16 bpp color depth at a 
reasonable resolution of 1280x1024. I do keep videoBIOS updated with recent 
version from Matrox. I have to admit that some of them were bad. The one (2.04)
before the last one (2.07) caused WinNT freezes under opengl screensavers for 
example. So, I would strongly advise updating videoBIOS too - there must be a 
reason for Matrox to keep tweaking videoBIOSes.  

I saw non-random crashes, however. For example, X crashes when NIS and NFS 
serving my account is dead for a while while I'm logged in. Another type of 
reproducible crash is described in bug 36682.
Comment 14 Mike A. Harris 2002-03-09 11:13:47 EST
Is this problem still present in rawhide?
Comment 15 Mike A. Harris 2002-05-28 00:08:32 EDT
Closing bug assuming it is fixed in XFree86 4.2.0 in Red Hat Linux 7.3
If the problem does persist however, please reopen the report.

Note You need to log in before you can comment on or make changes to this bug.