Bug 270741 - /sbin/kmodule ignores extra modules.
Summary: /sbin/kmodule ignores extra modules.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: initscripts   
(Show other bugs)
Version: 4.5
Hardware: All
OS: All
medium
low
Target Milestone: ---
: ---
Assignee: initscripts Maintenance Team
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-08-31 10:24 UTC by Gerd Hoffmann
Modified: 2007-11-17 01:14 UTC (History)
2 users (show)

Fixed In Version: RHBA-2007-0799
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 16:09:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
suggested fix. (519 bytes, patch)
2007-08-31 10:27 UTC, Gerd Hoffmann
no flags Details | Diff
different patch (1.82 KB, patch)
2007-09-04 15:03 UTC, Bill Nottingham
no flags Details | Diff
fix for the fix (419 bytes, patch)
2007-09-05 10:59 UTC, Gerd Hoffmann
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0799 normal SHIPPED_LIVE initscripts bug fix update 2007-11-14 18:39:19 UTC

Description Gerd Hoffmann 2007-08-31 10:24:46 UTC
Description of problem:
Autoloading drivers doesn't work for external modules which are installed below
/lib/modules/<version>/extra

Version-Release number of selected component (if applicable):
initscripts-7.93.31.EL-1

Comment 1 Gerd Hoffmann 2007-08-31 10:27:35 UTC
Created attachment 183041 [details]
suggested fix.

Patch makes kmodule additionally look in /lib/modules/<version>/extra and
/lib/modules/<version>/weak-updates.

Comment 2 Gerd Hoffmann 2007-08-31 16:11:22 UTC
Note: this change is needed for the xen pv-on-hvm drivers.

Comment 3 Bill Nottingham 2007-08-31 18:06:06 UTC
We don't rebuild these modules for each kernel?


Comment 4 Gerd Hoffmann 2007-09-03 07:26:53 UTC
We probably can rebuild them for each kernel, not sure yet what the process will
be.  But .../extra will be needed anyway for it to work.

While being at it I've added weak-modules too to avoid surprises because you
might have external modules in both directories, so if we search one we should
search the other one too.


Comment 5 Bill Nottingham 2007-09-04 15:03:55 UTC
Created attachment 186241 [details]
different patch

Does this work for you? It's a little bigger patch, but it's also more
future-proof.

Comment 6 Gerd Hoffmann 2007-09-05 10:59:08 UTC
Created attachment 187261 [details]
fix for the fix

Works after putting back in the uname() syscall.

For some strange reason it works the first time isAvailable() is called,
probably pure luck that the data from a previous  uname() syscall has the
correct location on the stack and wasn't overwritten yet.

Comment 7 Bill Nottingham 2007-09-05 18:05:47 UTC
devel ack on the patch. Exception is not for me to decide. :)

Comment 10 Bill Nottingham 2007-09-10 18:09:12 UTC
Added in 7.93.31.EL-2.

Comment 15 errata-xmlrpc 2007-11-15 16:09:58 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0799.html



Note You need to log in before you can comment on or make changes to this bug.