Bug 271141 - Vnc doesn't build against current versions of xorg-x11-server
Vnc doesn't build against current versions of xorg-x11-server
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
7
All All
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-31 08:44 EDT by Lubomir Kundrak
Modified: 2013-04-30 19:37 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.1.2-18.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 11:10:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Discussed patch (2.44 KB, text/plain)
2007-09-03 04:32 EDT, Adam Tkac
no flags Details

  None (edit)
Description Lubomir Kundrak 2007-08-31 08:44:49 EDT
Description of problem:

These lines from FC-7 vnc.spec bother me:

 56 BuildRequires: xorg-x11-server-source
...
 91 cp -r %{_datadir}/xorg-x11-server-source unix
...
102 pushd unix/xorg-x11-server-source*
103 %patch14 -p3 -b .s390
104 popd

The dependency on xorg-x11-server-source is unversioned and the s390 patch does
not apply against latest xorg-x11-server from both FC-7 and Rawhide.
Comment 1 Adam Tkac 2007-09-03 04:31:33 EDT
Better should be merge that patch to main Xorg branch or drop it. Ajax, what do
you think about this patch?
Comment 2 Adam Tkac 2007-09-03 04:32:46 EDT
Created attachment 185131 [details]
Discussed patch
Comment 3 Adam Jackson 2007-09-20 16:09:36 EDT
I'm not sure I like that patch.  We don't build the Xorg server for s390{,x} at
all right now, so there's really no point trying to build the vnc module for s390.

I'd just not build libvnc.so on s390 for now, but we probably want to fix s390
Xorg builds for real sometime.  (When we do, we won't bother with arch defines
in int10 at all, for example, because s390 doesn't have a PCI bus so there's no
possible way you'd want to build int10 support.)
Comment 4 Adam Tkac 2007-09-24 11:10:12 EDT
After inspection vnc will be built with --disable-xorg option so no patch is
needed. Commited into CVS but release will wait for more serious issue.

Note You need to log in before you can comment on or make changes to this bug.