Bug 271281 - inkscape generates segmentation fault upon starting
inkscape generates segmentation fault upon starting
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
7
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-31 09:32 EDT by origamifreak
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-31 09:56:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description origamifreak 2007-08-31 09:32:01 EDT
Description of problem:
Segmentation fault when starting

Version-Release number of selected component (if applicable):
inkscape.i386 0.45.1-1.fc7

Platform:
Linux kadu 2.6.22.4-65.fc7 #1 SMP Tue Aug 21 22:36:56 EDT 2007 i686 i686 i386
GNU/Linux

How reproducible:
% inkscape
Segmentation fault

Steps to Reproduce:
1. invoke inkscape

Additional info:
Core was generated by `inkscape'.
Program terminated with signal 11, Segmentation fault.
#0  0x0022a5cb in GC_malloc () from /usr/lib/libgc.so.1
(gdb) where
#0  0x0022a5cb in GC_malloc () from /usr/lib/libgc.so.1
#1  0x085bbf56 in sp_repr_new ()
#2  0x085b8104 in ?? ()
#3  0x085b9797 in ?? ()
#4  0x085b98c8 in sp_repr_read_mem ()
#5  0x081c9022 in Inkscape::Preferences::loadSkeleton ()
#6  0x082b18b7 in Inkscape::NSApplication::Application::Application ()
#7  0x081b61f5 in main ()
Comment 1 Denis Leroy 2007-08-31 09:43:36 EDT
Hmm, worksforme. And that's on i386 ? I thought that problem was fixed since the
gc update. What version of gc do you have installed ("rpm -q gc") ?
Comment 2 origamifreak 2007-08-31 09:49:19 EDT
% rpm -q gc
package gc is not installed

That's weird, because yum says it's there:

# yum install gc
Setting up Install Process
Parsing package install arguments
Package libgc - 1:7.0-1.fc7.rf.i386 already installed and latest version
Nothing to do
Comment 3 origamifreak 2007-08-31 09:51:41 EDT
I guess rpm wants the full name.

# rpm -q libgc
libgc-7.0-1.fc7.rf
Comment 4 Denis Leroy 2007-08-31 09:56:43 EDT
Please use the official libgc from Fedora. I can't help you with third-party
RPMs. This was a known problem that we patched a month ago or so.
Comment 5 Denis Leroy 2007-08-31 09:58:03 EDT
i.e.

rpm -e libgc
yum -y install gc

:-)
Comment 6 origamifreak 2007-08-31 10:03:22 EDT
Awesome.  gc-6.8-3.fc7 works great.

Thanks so much, and sorry to have bothered you!

Note You need to log in before you can comment on or make changes to this bug.