Bug 27143 - rpm thinks newer version of program is older
rpm thinks newer version of program is older
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-12 09:33 EST by Gerald Henriksen
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-12 09:33:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Henriksen 2001-02-12 09:33:13 EST
Tried to update from gnomeicu 0.93 to 0.95.2 and got the following:

/home/ghenriks $ rpm -Uvh gnomeicu-0.95.2-1.i386.rpm 
Preparing...                ###########################################
[100%]
package gnomeicu-0.93-5 (which is newer than gnomeicu-0.95.2-1) is already
installed
Comment 1 Jeff Johnson 2001-02-12 10:10:36 EST
Look for an epoch in the gnomeicu-0.93-5 package:
	rpm -q --qf 'Epoch: %{epoch}\n' gnomeicu
Do the same with the 0.95 package, you'll need "-qp" instead of "-q".

Epoch's in packages take precedence over version-release comparisons. In fact,
the higher numbered epoch is always "newer", not matter what the version-release
tags are.
Comment 2 roystgnr 2001-03-01 23:21:11 EST
Ah, so then all my RPMs with those confusing "1.0.9" and "1.2.5" type version
numbers are being ignored in favor of the simple "Epoch: 1" flags in their
"1.0.7", "1.2.4" predecessors.  That explains all of my Gnome RPMs that the
fisher beta overwrote with older versions, too.

Whose dumb idea was this, and which files do I patch to fix it?

-- Roy Stogner, having lots of fun with the --oldpackage flag and
gnome-1.4-beta2 tonight.
Comment 3 roystgnr 2001-03-01 23:26:21 EST
Ah, so then all my RPMs with those confusing "1.0.9" and "1.2.5" type version
numbers are being ignored in favor of the simple "Epoch: 1" flags in their
"1.0.7", "1.2.4" predecessors.  That explains all of my Gnome RPMs that the
fisher beta overwrote with older versions, too.

Whose dumb idea was this, and which files do I patch to fix it?

-- Roy Stogner, having lots of fun with the --oldpackage flag and
gnome-1.4-beta2 tonight.
Comment 4 roystgnr 2001-03-01 23:31:20 EST
Grr.. sorry about the double comment; somehow the back button from the bugzilla
"comment added" page managed to resubmit things.  While I'm at it, sorry for the
sarcastic rant.  It just annoys me greatly that now that we have things like Red
Carpet working well to install "channels" of RPMs, this new "Epoch" version
numbering will make it impossible to install RPMs from multiple developer
groups.  How am I supposed to install Ximian Gnome 2.0 (Epoch 13) next year when
it's guaranteed to be overwritten by Red Hat Gnome 1.4 (Epoch 15) because Red
Hat happened to be making packages more often?

Note You need to log in before you can comment on or make changes to this bug.