Bug 27147 - Dell LS500 - Frame Buffer support causes purple text consoles
Summary: Dell LS500 - Frame Buffer support causes purple text consoles
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-12 15:28 UTC by David Sainty
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-22 19:05:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ddcprobe from fisher (458 bytes, text/plain)
2001-02-14 01:20 UTC, David Sainty
no flags Details
XF86Config.test created by fisher install (3.32 KB, text/plain)
2001-02-14 01:23 UTC, David Sainty
no flags Details

Description David Sainty 2001-02-12 15:28:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-0.99.24 i686; en-US; m18)
Gecko/20010208


Upon gui Anaconda install, when X starts using frame buffer, all text
consules (e.g. tty2) are subsequently purple in colour. When swapping from
X to tty2 the X screen first changes to purple, and then the new console is
displayed.

I tested using vga=787 on an installed system, and once X is started (in
800x600x64k) again the other consoles change to purple from the standard
"grey". I installed kernel-2.4.0-0.99.24 and XFree86-*-4.0.2-7 and the
problem still exists.

Reproducible: Always
Steps to Reproduce:
1.Start gui anaconda installation
2.Change to tty2 (<ctrl><alt>2)
3.
	

Actual Results:  Frame buffer support on LS500 gives purple consoles.

Expected Results:  Normal colour consoles.

Comment 1 Michael K. Johnson 2001-02-14 00:23:32 UTC
It works correctly until X starts, right?

Comment 2 David Sainty 2001-02-14 01:03:05 UTC
Yes, that's correct. The kernel loads, we get correct text for the kernel
messages, we probe for video, X then starts with the correct colour. The problem
is moving from the 800x600 X display back to a text console (<Ctrl><Alt><F2>).
Moving back to the X display (<Ctrl><Alt><F7>) restores the X display with the
correct colours again.

I'm attaching the ddcprobe and the XF86Config.test for you also.

I can test any patches you have.


David S..

Comment 3 David Sainty 2001-02-14 01:20:33 UTC
Created attachment 9967 [details]
ddcprobe from fisher

Comment 4 David Sainty 2001-02-14 01:23:10 UTC
Created attachment 9968 [details]
XF86Config.test created by fisher install

Comment 5 David Sainty 2001-02-22 19:05:03 UTC
Looks to be fixed in standard wolverine installation from CD.  Could this have
been a 15bpp/16bpp issue?


Comment 6 Mike A. Harris 2001-02-22 19:26:04 UTC
No idea.  Every new XFree package is resync'd with XFree86 stable branch
of CVS via patch #0 though, so it is possible a new fix got in that I didn't
see.  I'm closing this since you say it is fixed now.  Hope that is ok.

Comment 7 David Sainty 2001-02-23 19:40:18 UTC
So you know...  vga=788 fixes this.  Installation for wolverine now uses vga=788
instead of vga=787 which was used previously, and as I recall the difference
between 787 and 788 is the bpp. Now we have a properly resolved bug. :-)


David S..


Note You need to log in before you can comment on or make changes to this bug.