Bug 273361 - SDC Configuration Overview checkbox , top one, inop
Summary: SDC Configuration Overview checkbox , top one, inop
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site   
(Show other bugs)
Version: rhn500
Hardware: All
OS: All
low
low
Target Milestone: ---
Assignee: Bill C. Riemers
QA Contact: Sebastian Skracic
URL: https://rhn.webqa.redhat.com/rhn/syst...
Whiteboard:
Keywords: Reopened
: 369351 (view as bug list)
Depends On:
Blocks: 369351 428842
TreeView+ depends on / blocked
 
Reported: 2007-08-31 21:54 UTC by joseph canton
Modified: 2008-04-07 20:01 UTC (History)
2 users (show)

Fixed In Version: 5.0.5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 20:01:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of Configuraiton overview w/ checkbox's (149.89 KB, image/jpeg)
2007-08-31 21:54 UTC, joseph canton
no flags Details

Description joseph canton 2007-08-31 21:54:28 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:entitle 1 system with provisioning, create a single centrally
manage configuration file. subscribe the 1 system to the centrally managed
config file. Then  System -> pick system -> Configuration, View/Modify
Files/Centrally-managed Files.

Top checkbox dosent check other boxes.
Steps to Reproduce:
1.nav to Systems->(aprovisioned system)-> Configuration
2.-> view/Modify Files
3.
  
Actual results:
To checkbox next to "File Name" show, but dosent work.
detected with a single line item as shown in the attached jpg.
Expected results:


Additional

Comment 1 joseph canton 2007-08-31 21:54:28 UTC
Created attachment 184041 [details]
screenshot of Configuraiton overview w/ checkbox's

Comment 2 Grant Gainey 2007-09-11 14:21:21 UTC
The "process_check_all" JS function never made it into the HOSTED svn tree.  The
affected file in the SAT tree is /svn/trunk/eng/web/html/javascript/check_all.js.

There are a number of changes in this file; I'm not comfortable trying to do
this quickly, after we've already pushed into QA.  Therefore I'm moving this bug
to 504.

Comment 3 Grant Gainey 2007-10-18 15:34:45 UTC
See plan-to-reproduce - checking the top box should now select all files

Comment 4 joseph canton 2007-10-22 19:44:22 UTC
verified

Comment 5 Bill C. Riemers 2008-02-07 19:34:00 UTC
It looks like only the respective Ajax code was never added to rhn-hosted. 
Thus, the other check box functions were broken by the "fix".


Comment 6 Bill C. Riemers 2008-02-08 19:14:50 UTC
Missing satellite code added to host.

Comment 7 Bill C. Riemers 2008-02-08 19:19:15 UTC
*** Bug 369351 has been marked as a duplicate of this bug. ***

Comment 8 Bill C. Riemers 2008-02-08 19:20:31 UTC
Please test the procedure described in 369351 as well as this one.

Comment 10 Sebastian Skracic 2008-03-18 14:21:22 UTC
Verifed against webqa.


Note You need to log in before you can comment on or make changes to this bug.