Bug 273481 - Mock fails installing glib2-devel
Mock fails installing glib2-devel
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
7
x86_64 All
medium Severity low
: ---
: ---
Assigned To: Michael E Brown
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-08-31 20:24 EDT by Jonathan Steffan
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-31 22:28:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Steffan 2007-08-31 20:24:10 EDT
Description of problem:
When Requires: glib2-devel and BuildArch: x86_64, build fails. Example:

$ mock -r fedora-5-x86_64-epel libgdiplus-1.2.3-1.fc7.src.rpm 
init
clean
prep
This may take a while
unpack cache
setup
Error: Missing Dependency: libgmodule-2.0.so.0 is needed by package glib2-devel
Error: Missing Dependency: libgthread-2.0.so.0 is needed by package glib2-devel
Error: Missing Dependency: libglib-2.0.so.0 is needed by package glib2-devel
Error: Missing Dependency: libgobject-2.0.so.0 is needed by package glib2-devel

Error performing yum command: /usr/sbin/mock-helper yum --installroot
/var/lib/mock/epel-5-x86_64/root install  'zlib-devel' 'libungif-devel'
'libjpeg-devel' 'glib2-devel' 'libXt-devel' 'freetype-devel' 'cairo-devel'
'libpng-devel' 'libtiff-devel'
ending
done

Version-Release number of selected component (if applicable):
mock-0.7.4-1.fc7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. wget
http://download.fedora.redhat.com/pub/fedora/linux/releases/7/Everything/source/SRPMS/libgdiplus-1.2.3-1.fc7.src.rpm
2. mock -r fedora-5-x86_64-epel libgdiplus-1.2.3-1.fc7.src.rpm

Actual results:
Errors.

Expected results:
Build.

Additional info:
The following change helps:

exclude=[ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefhijklmnopqrstuvwxyz]*.i*86
g[abcdefghijkmnopqrstuvwxyz]*.i?86 glib2.i?86 glib.i?86 glib2-devel.i?86
glib-devel.i?86
Comment 1 Jonathan Steffan 2007-08-31 20:24:59 EDT
s/Requires/BuildRequires/
Comment 2 Michael E Brown 2007-08-31 20:57:21 EDT
Doesnt appear to be a mock problem to me. Looks like a yum problem. Yum is
saying that it cannot find the dependencies needed by glib2-devel. Are you sure
they are present in your repo?
Comment 3 Jonathan Steffan 2007-08-31 21:09:04 EDT
Yes, they are there.

$ sudo yum --installroot /var/lib/mock/epel-5-x86_64/root install glib2-devel -d 2
Setting up Install Process
Parsing package install arguments
Excluding Packages in global exclude list
Finished
Excluding Packages from local
Finished
Resolving Dependencies
--> Running transaction check
---> Package glib2-devel.i386 0:2.12.3-2.fc6 set to be updated
---> Package glib2-devel.x86_64 0:2.12.3-2.fc6 set to be updated
--> Processing Dependency: libgobject-2.0.so.0 for package: glib2-devel
--> Processing Dependency: libgthread-2.0.so.0 for package: glib2-devel
--> Processing Dependency: libc.so.6(GLIBC_2.0) for package: glib2-devel
--> Processing Dependency: libc.so.6(GLIBC_2.1) for package: glib2-devel
--> Processing Dependency: libc.so.6 for package: glib2-devel
--> Processing Dependency: libglib-2.0.so.0 for package: glib2-devel
--> Processing Dependency: pkgconfig >= 1:0.8 for package: glib2-devel
--> Processing Dependency: librt.so.1 for package: glib2-devel
--> Processing Dependency: libgmodule-2.0.so.0 for package: glib2-devel
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package pkgconfig.x86_64 1:0.21-1.fc6 set to be updated
---> Package glibc.i686 0:2.5-12 set to be updated
---> Package glib2-devel.i386 0:2.12.3-2.fc6 set to be updated
---> Package glib2-devel.x86_64 0:2.12.3-2.fc6 set to be updated
--> Processing Dependency: libglib-2.0.so.0 for package: glib2-devel
--> Processing Dependency: libgobject-2.0.so.0 for package: glib2-devel
--> Processing Dependency: libgthread-2.0.so.0 for package: glib2-devel
--> Processing Dependency: libgmodule-2.0.so.0 for package: glib2-devel
--> Finished Dependency Resolution
Error: Missing Dependency: libgobject-2.0.so.0 is needed by package glib2-devel
Error: Missing Dependency: libgthread-2.0.so.0 is needed by package glib2-devel
Error: Missing Dependency: libglib-2.0.so.0 is needed by package glib2-devel
Error: Missing Dependency: libgmodule-2.0.so.0 is needed by package glib2-devel

As I tried to point out, excluding the 32bit glib2-devel fixes the issue.
Comment 4 Michael E Brown 2007-08-31 22:28:15 EDT
Oh. Well I completely missed that part. Sorry.

Thanks for the info. I have added that to the default config. It will be in the
next release. I wonder if the same fix is needed for FC6, F7/F8? I've sent a
query to fedora-buildsys-list to ask.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.