Bug 273521 - autofs does not work on Fedora 7 after updating to autofs-5.0.1-25
autofs does not work on Fedora 7 after updating to autofs-5.0.1-25
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: autofs (Show other bugs)
7
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeffrey Moyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-01 00:54 EDT by Khem Raj
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.0.1-27
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-02 22:39:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Khem Raj 2007-09-01 00:54:44 EDT
Description of problem:

Autofs is not working for me any more after upgrading to autofs-5.0.1-25
autofs-5.0.1-23 worked ok.

Version-Release number of selected component (if applicable):

autofs-5.0.1-25

How reproducible:


Steps to Reproduce:
1. Restart autofs after installing the update
Actual results:

Aug 31 20:09:32 apollo kernel: automount[2008]: segfault at 00002aaaace38440 rip 
00002aaaace38440 rsp 00000000405260f8 error 14
Aug 31 20:09:46 apollo kernel: automount[2677] general protection rip:2aaaab326b3d 
rsp:7fffa91acbd0 error:0
Aug 31 21:31:40 apollo kernel: automount[28450] general protection rip:2aaaab326b3d 
rsp:7fff22a964c0 error:0
Aug 31 21:41:04 apollo kernel: automount[28582] general protection rip:2aaaab326b3d 
rsp:7fffd7ed48f0 error:0
Aug 31 21:41:08 apollo kernel: automount[28606] general protection rip:2aaaab326b3d 
rsp:7fff6d7c11e0 error:0


Expected results:

Autofs should have restarted 

Additional info:

* Tue Aug 21 2007 Ian Kent <[EMAIL PROTECTED]> - 5.0.1-25
- change random multiple server selection option name to be consistent
  with upstream naming.
* Tue Aug 21 2007 Ian Kent <[EMAIL PROTECTED]> - 5.0.1-24
- don't fail on empty master map.
- allow for older schemas that allow "*" as a key value.
- add support for the "%" hack for case insensitive attribute schemas.
Comment 1 Khem Raj 2007-09-01 00:55:38 EDT
I am using autofs over LDAP and system is x86-64
Comment 2 Khem Raj 2007-09-01 00:59:54 EDT
hmm the faulting version is 5.0.1-26 not 5.0.1-25 as I mentioned earlier.
Comment 3 Khem Raj 2007-09-01 01:04:15 EDT
oh well I tried the testing version 5.0.1-27 for koji and the problem is fixed there. So I think this can be 
closed when the update it pushed
Comment 4 Ian Kent 2007-09-02 22:39:07 EDT
(In reply to comment #3)
> oh well I tried the testing version 5.0.1-27 for koji and the problem is fixed
there. So I think this can be 
> closed when the update it pushed

Yep, I reverted the broken patch.
I'm still not sure what I did wrong there but it will
have to wait till I get time to return to it.

Ian
Comment 5 Jeffrey Moyer 2007-09-03 08:23:32 EDT
DEFERRED is the wrong status.  Take a look at:

https://bugzilla.redhat.com/page.cgi?id=bug_status.html#resolution

for an explanation of the resolution statuses.

Note You need to log in before you can comment on or make changes to this bug.