Bug 27370 - rio500 and .fon files are bad file formats
Summary: rio500 and .fon files are bad file formats
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: i686 Linux
low
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-13 09:16 UTC by tanner
Modified: 2007-03-27 03:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-13 09:16:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description tanner 2001-02-13 09:16:39 UTC
Compiling the rio500 utilities for Redhat 7.0 and RPM does not recognize
the .fon file format:

objdump: /var/tmp/rio500-0.7-root/usr/share/rio500/fonts/6581.fon: File
format not recognized
objdump: /var/tmp/rio500-0.7-root/usr/share/rio500/fonts/amiga.fon: File
format not recognized
objdump: /var/tmp/rio500-0.7-root/usr/share/rio500/fonts/amplitud.fon: File
format not recognized
objdump: /var/tmp/rio500-0.7-root/usr/share/rio500/fonts/atopaz.fon: File
format not recognized
objdump: /var/tmp/rio500-0.7-root/usr/share/rio500/fonts/blackout.fon: File
format not recognized
objdump: /var/tmp/rio500-0.7-root/usr/share/rio500/fonts/camels.fon: File
format not recognized
objdump: /var/tmp/rio500-0.7-root/usr/share/rio500/fonts/cbm64.fon: File
format not recognized
<snip>

I think this is because the magic-cookie of the file .fonts file is is
detected as an MS-DOS executable:

% file ../BUILD/rio500-0.7/fonts/6581.fon 
../BUILD/rio500-0.7/fonts/6581.fon: MS-DOS executable (EXE), OS/2 or MS Windows

Source code is available here:
http://sourceforge.net/projects/rio500/

Comment 1 Jeff Johnson 2001-02-13 14:34:04 UTC
This is a packaging problem, not an rpm problem. Remove the executable bits from
the
font files in the %install section of the spec file and the message(s) will go
away. Or simply
ignore the messages, there's nothing wrong with objdump complaining when fed a
font file as input.


Note You need to log in before you can comment on or make changes to this bug.