Bug 27374 - [RFE] up2date should show old versions numbers too
[RFE] up2date should show old versions numbers too
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
: FutureFeature
: 32581 58917 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-13 06:09 EST by Vidar Langseid
Modified: 2015-01-07 18:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-26 20:17:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vidar Langseid 2001-02-13 06:09:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16 i686)


When using up2date, both in console and the GUI, the user should also be
informed about which version is currently installed on the system.

At present, up2date only shows the version numbers for the new packages.

Reproducible: Always
Steps to Reproduce:
1. up2date -l
2.
3.
	

Actual Results:  Name                                    Version       
Rel  Reason
-------------------------------------------------------------------------------
kernel                                  2.2.17         14   Pkg
name/pattern

Expected Results:  Name             Installed version      Version       
Rel  Reason
-------------------------------------------------------------------------------
kernel                   2.2.16-22      2.2.17         14   Pkg
name/pattern
Comment 1 Daniel Roesen 2001-02-14 11:28:53 EST
Good idea! Seconded.
Comment 2 Cristian Gafton 2001-02-19 20:32:31 EST
Assigned QA to jturner
Comment 3 Preston Brown 2001-02-20 13:10:32 EST
tmay or may not make it.  We are 80 cols limited...
Comment 4 Vidar Langseid 2001-02-21 04:12:16 EST
Is the 80 cols limit absolute ?
If you don't want to brake the 80 cols limit by default, could it be done if the
user spesifies a extra parameter

Something like

# up2date -l --verbose
Comment 5 Adrian Likins 2002-05-16 15:18:39 EDT
*** Bug 32581 has been marked as a duplicate of this bug. ***
Comment 6 Adrian Likins 2002-05-16 17:55:35 EDT
*** Bug 58917 has been marked as a duplicate of this bug. ***
Comment 7 Adrian Likins 2002-05-16 19:16:40 EDT
any suggests on how to cram all that info in there? seems like
I need:

[] name-version-release.arch name-version-release.arch size

but name-version-release.arch can be pretty large... I could
drop the name off the old version, but in cases of obsoletes
that might not make sense...

If I ignore the obsoletes I could do:

[] name version-release.arch version-release-arch size

and maybe in the case of obsoletes, something lise

[] name version-release.arch (obsoletes)name size

since this is the main interactive bit of up2date, I'd
rather not make the ui more confusing.
Comment 8 Adrian Likins 2003-06-19 20:53:52 EDT
added in 3.1.35

Note You need to log in before you can comment on or make changes to this bug.