Bug 27376 - module-info missing on enterprise kernels (was kernel, kernel-smp and kernel-enterprise are mutually exclusive, oh my)
module-info missing on enterprise kernels (was kernel, kernel-smp and kernel-...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-13 07:21 EST by Arenas Belon, Carlo Marcelo
Modified: 2007-03-26 23:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-19 11:49:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for fixing the broken link on -enterprise kernels and also providing module-info for kernelcfg pleasure (1.26 KB, patch)
2001-03-28 22:28 EST, Arenas Belon, Carlo Marcelo
no flags Details | Diff

  None (edit)
Description Arenas Belon, Carlo Marcelo 2001-02-13 07:21:24 EST
Granted, you can have all of them installed at the same time and select
which one to use at boot time with lilo.

but you would be loosing space on /boot and have no change to have :

  Provides: module-info

for every kernel type.

as a result, there is a missing link for module-info on the -smp and
-enterprise kernels and the %post script are making broken links for
module-info as a result.
Comment 1 Arenas Belon, Carlo Marcelo 2001-03-28 22:28:35 EST
Created attachment 14063 [details]
Patch for fixing the broken link on -enterprise kernels and also providing module-info for kernelcfg pleasure
Comment 2 Arenas Belon, Carlo Marcelo 2001-03-28 22:37:00 EST
ok, now i am not aslept and i think my english is hardly improving ;)

i think the principal problem (module-info with a broken link on
kernel-enterprise installs) could be fixed with just adding a line on the %files
for enterprise kernels including the module-info%{KVERREL}enterprise file.

a really simple patch is attached (against the 2.2.17-14's spec) that is at
least technically correct.

a nice touch would be also to Provide: module-info for kernel-smp,
kernel-enterprise and kernel-jensen (whatever is that)

please forgive my explanation about making all the kernel packages mutually
exclusive, i guess i am not me sometimes :(
Comment 3 Arenas Belon, Carlo Marcelo 2001-03-28 22:41:32 EST
BTW as a side comment bug 28411 seems related to this one and even as it seems
fixed on errata for -4 the problem was still present on the final errata with
release -14
Comment 4 Bill Nottingham 2003-02-19 11:49:49 EST
This should be working now, I think.

Note You need to log in before you can comment on or make changes to this bug.