Bug 27412 - Glitches with 3c90x driver
Glitches with 3c90x driver
Status: CLOSED DEFERRED
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
: 29093 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-13 11:06 EST by Sammy
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-23 14:45:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sammy 2001-02-13 11:06:56 EST
Hi, I had two problems with 3c90x:

1. If you compile into the kernel (not as a module), somehow the
   card is not detected at boot.

2. When it is loaded as a module it gives the error message:

   ..................3c90x.o: ... switchdelay has max < min!  
 
   the drivers does work but this is an annoying message that shows
   up on the boot screen and makes people come and tell me that there
   is an error message! We did not have this with 2.2.x kernels.
Comment 1 Michael K. Johnson 2001-02-13 19:51:26 EST
Which exact kernel version do you have?
Comment 2 Sammy 2001-02-16 11:58:03 EST
Sorry, I never have the needinfo case on when I look at bugzilla!

My kernel version is 2.4.1-acxx I build my own kernel rpms just for
fun! 3c90x patch is from your source rpm. I also used the option
switchdelay=0 but did not change anything.

Is there another patch in 2.4.0-99.xx that fixes this?
Comment 3 Michael K. Johnson 2001-02-16 12:21:40 EST
No, there is currently no new patch.

I have forwarded this to 3com
Comment 4 Michael K. Johnson 2001-02-23 14:45:09 EST
*** Bug 29093 has been marked as a duplicate of this bug. ***
Comment 5 Michael K. Johnson 2001-02-23 15:17:10 EST
3com has not responded.  The bug was trivial to fix, but raised
questions about the validity of other parts of the code.  Given
the other bug reports we are hearing, and the fact that the 3c59x
driver supports all the same hardware, I have disabled this driver
for now.
Comment 6 Sammy 2001-03-06 16:20:35 EST
Just as an additional info....I found that I get that message if kudzu
uses the device eth in /etc/sysconfig/hwconf instead of the old sgk.
With sgk there is no message.

Note You need to log in before you can comment on or make changes to this bug.