Bug 274371 - fedora won't boot with kernel 2.6.23-0.149.rc4.fc8
fedora won't boot with kernel 2.6.23-0.149.rc4.fc8
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All All
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-02 04:34 EDT by Valent Turkovic
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 18:15:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valent Turkovic 2007-09-02 04:34:44 EDT
Description of problem:
fedora won't boot with kernel 2.6.23-0.149.rc4.fc8 but it boots ok with kernel
2.6.23-0.71.rc2.fc8

Version-Release number of selected component (if applicable):
kernel 2.6.23-0.149.rc4.fc8

How reproducible:
every time

Steps to Reproduce:
1. turn on the machine
2. choose kernel 2.6.23-0.149.rc4.fc8 from grub menu
3.
  
Actual results:
it complains about unable to mount /sys / and other partitions... I can't find
it in log files because it is obviously now writen into when noting is mounted.

Expected results:
to boot up fabulous fedora :)

Additional info:
tell me what do you need and how can I give you more feedback.
Comment 1 Valent Turkovic 2007-09-02 04:37:57 EDT
this fixes it:

# mv /boot/initrd-2.6.23-0.149.rc4.fc8.img
/boot/initrd-2.6.23-0.149.rc4.fc8.img.orig

# mkinitrd /boot/initrd-2.6.23-0.149.rc4.fc8.img 2.6.23-0.149.rc4.fc8
Comment 2 Dave Jones 2007-09-14 13:07:56 EDT
probably transient mkinitrd breakage.  Should be ok now? 
Comment 3 Valent Turkovic 2007-09-16 03:54:27 EDT
after issuing mkinitrd command that fixes it, but I didn't test if it works if I
put "/boot/initrd-2.6.23-0.149.rc4.fc8.img.orig" back. Do you want me to try it?
It that what you had in mind?
Comment 4 Dave Jones 2007-09-19 15:42:00 EDT
just install the latest kernel with yum.  If that boots without you having to
mess around with mkinitrd at all, then we can close this.
Comment 5 Valent Turkovic 2007-09-20 02:11:09 EDT
jup, latest kernel works ok.

Linux fedora7 2.6.23-0.29.rc0.git6.fc8 

Note You need to log in before you can comment on or make changes to this bug.