Bug 27440 - [eepro100] eth0 - no resources
[eepro100] eth0 - no resources
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-13 15:42 EST by Wade Minter
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-13 17:55:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Corrected e100 patch to build correctly (337.17 KB, patch)
2001-02-14 11:04 EST, Michael K. Johnson
no flags Details | Diff

  None (edit)
Description Wade Minter 2001-02-13 15:42:02 EST
The networking on a Big Sur dual B3-800, 4GB RAM machine is very flaky. 
When the network goes crappy, a message such as the following will be sent
to the syslog:

Feb 13 12:16:21 pilot kernel: eth0: card reports no resources.
Feb 13 12:19:44 pilot kernel: eth0: card reports no resources.
Feb 13 12:19:45 pilot kernel: eth0: card reports no resources.
Feb 13 12:22:47 pilot kernel: eth0: card reports no resources.
 
The card is reported as:

Feb 13 13:01:01 pilot kernel: eth0: Intel Corporation 82557 [Ethernet Pro
100], 00:03:47:16:E9:AA, I/O at 0x1000, IRQ 49.
Comment 1 Jeff Johnson 2001-02-13 16:41:31 EST
This is an ia64 kernel problem, changing component
Comment 2 Arjan van de Ven 2001-02-13 17:53:00 EST
What is the exact kernel version ?
Comment 3 Wade Minter 2001-02-13 17:55:15 EST
2.4.0-0.99.11smp, the stock one from fisher.
Comment 4 Michael K. Johnson 2001-02-13 20:06:58 EST
This is a known eepro100 driver problem.  It may be fixed in a
later version of the eepro100 driver that will be in our next
released kernel, and it may also be fixed in the e100 driver
that will also be in that kernel.  One way or the other, it is
likely to be fixed in our next released kernel, so I'm marking
this resolved RAWHIDE.  Re-open it if I am wrong.
Comment 5 Wade Minter 2001-02-13 21:55:56 EST
Any ETA on the new kernel?  We're being forced to use TurboLinux until a
workaround for this is implemented.
Comment 6 Michael K. Johnson 2001-02-14 11:03:17 EST
I can only say shortly -- we're looking into a few other bug reports
because we don't want to release one new kernel each day...  I'll
attach the fixed e100 patch that can be dropped into the sources
directory in place of the existing linux-2.2.17-e100.patch to rebuild
the kernel if you like as a workaround for the meantime.

rpm -i kernel-2.2.17-14.src.rpm
cd /usr/src/redhat/SOURCES
<copy the attachment to linux-2.2.17-e100.patch>
cd ../SPECS
rpm -ba kernel-2.2.spec
rpm -ba kernel-2.2.spec --target i686
                             (or i586)
Comment 7 Michael K. Johnson 2001-02-14 11:04:11 EST
Created attachment 10024 [details]
Corrected e100 patch to build correctly
Comment 8 Michael K. Johnson 2001-02-14 13:38:48 EST
Sorry, wrong bug report, please ignore what I wrote above.
It's for a completely different bug with a similar title...

I don't yet have an ETA on the IA-64 kernel.

Note You need to log in before you can comment on or make changes to this bug.