Bug 27466 - nsupdate doesn't work
nsupdate doesn't work
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: bind (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
: 27467 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-13 19:50 EST by Chris Ricker
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-15 20:07:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2001-02-13 19:50:33 EST
All attempts to use nsupdate for me just seg-fault.  Here's a test example.

I'm at 10.100.0.12 running named locally, configured as follows:

zone "testdomain12.com" {
        type master;
        file "master/db.testdomain12.com";
        allow-update { 10.100.0.12; 10.100.52.23; 127.0.0.1; };
};

Now, I try an nsupdate:

[root@station12 master]# nsupdate -d
> update add test.testdomain12.com 3600 a 10.100.0.12
>
Reply from SOA query:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id:  27778
;; flags: qr aa rd ra ; QUESTION: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0
;; QUESTION SECTION:
;test.testdomain12.com.         IN      SOA

;; AUTHORITY SECTION:
testdomain12.com.       0       IN      SOA     station12.example.com.
hostmaster.testdomain12.com. 2001021307 10800 60 3600000 43200


Found zone name: testdomain12.com
The master is: station12.example.com
Segmentation fault
[root@station12 master]#
Comment 1 Chris Ricker 2001-02-13 19:59:08 EST
*** Bug 27467 has been marked as a duplicate of this bug. ***
Comment 2 Glen Foster 2001-02-15 20:07:10 EST
This defect is considered MUST-FIX for Florence Release-Candidate #2
Comment 3 Bernhard Rosenkraenzer 2001-02-27 13:12:20 EST
Fixed in 9.1.0-5. You'll also need to update your glibc.

Note You need to log in before you can comment on or make changes to this bug.