Bug 274731 - Inconsistent md5sum for /usr/share/avahi/service-types.db between rpm's
Inconsistent md5sum for /usr/share/avahi/service-types.db between rpm's
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: avahi (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
: 340721 378221 404891 407481 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-02 18:53 EDT by Hal Duston
Modified: 2007-12-28 12:13 EST (History)
7 users (show)

See Also:
Fixed In Version: 0.6.21-8.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-28 12:13:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hal Duston 2007-09-02 18:53:38 EDT
Description of problem:

In the the x86_64 devel repository, the x86_64 and i386 rpm's of avahi, the
/usr/share/avahi/service-types.db file has different md5sum's causing the two
rpm's not to be able to both be installed simultaneously.  The i386 rpm ends up
being required to resolve deps for the firefox.i386 rpm.

Version-Release number of selected component (if applicable):

avahi-0.6.21

How reproducible:

Always

Steps to Reproduce:
1. yum -y install avahi.x86_64
2. yum -y install avahi.i386
3. 
  
Actual results:

Observe "Transaction check, ... file conflicts"

Expected results:

Both rpm's installed w/o issue.

Additional info:

I used --force to install the second rpm.
Comment 1 Lennart Poettering 2007-09-06 13:31:00 EDT
Hmm, I wonder why they differ? Anyone knows whether the gdbm disk format is CPU
dependant? If so, we probably should be moving service-types.db to /usr/lib/
Comment 2 Lennart Poettering 2007-09-06 13:35:54 EDT
OK, I checked this now. gdbm on-disk formt is indeed different for 64bit and 32bit. 

I will move the .db file to /usr/lib in the next upstream avahi release.
Comment 3 Lennart Poettering 2007-09-06 16:12:27 EDT
This is now fixed upstream in SVN r1537 which will find its way in Avahi 0.6.22
which I will eventually push into rawhide.

http://avahi.org/ticket/171
Comment 4 Lennart Poettering 2007-10-21 18:06:47 EDT
*** Bug 340721 has been marked as a duplicate of this bug. ***
Comment 5 Lubomir Kundrak 2007-11-25 15:15:52 EST
Lennart, would it be possible to get this fixed in F8?
Comment 6 Lennart Poettering 2007-11-29 18:53:41 EST
*** Bug 378221 has been marked as a duplicate of this bug. ***
Comment 7 Lennart Poettering 2007-11-29 18:53:49 EST
*** Bug 404891 has been marked as a duplicate of this bug. ***
Comment 8 Valdis Kletnieks 2007-11-29 22:36:01 EST
Should this bug still be sitting in NEEDINFO status, or should it be changed to
CLOSED/UPSTREAM?
Comment 9 Lennart Poettering 2007-12-04 02:34:49 EST
*** Bug 407481 has been marked as a duplicate of this bug. ***
Comment 10 Bjorge Solli 2007-12-17 08:58:36 EST
This bug seems to seriously damage Gnome on FC8. What can be done to get this
upstream ASAP?

http://dpaste.com/hold/28268/
Comment 11 Lubomir Kundrak 2007-12-17 09:06:26 EST
Lennart: As you can see, this is causing pain to lot of users. It is definitely
something that should be fixed in Fedora 8. Would you mind if I rolled the update?
Comment 12 Lennart Poettering 2007-12-17 13:15:23 EST
Fix in Rawhide.

Lubomir: Dating this up is not trivial, because you need to fix the paths
properly everywhere. You're welcome to update the F8 patches, however. 

I would not recommend pulling 0.6.22 into F8 though, since it contains a lot of
additional changes.
Comment 13 Fedora Update System 2007-12-20 15:12:39 EST
avahi-0.6.21-8.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update avahi'
Comment 14 Fedora Update System 2007-12-28 12:13:16 EST
avahi-0.6.21-8.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.