Bug 274761 - dhclient-script destroys NTPD configuration
dhclient-script destroys NTPD configuration
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
7
All Linux
medium Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-02 21:09 EDT by Björn Persson
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 3.0.5-39.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 12:43:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
makes dhclient-script manage its own lines and leave others alone (858 bytes, patch)
2007-09-02 21:09 EDT, Björn Persson
no flags Details | Diff
makes dhclient-script manage its own lines and leave others alone – unified diff (1.19 KB, patch)
2007-09-03 05:15 EDT, Björn Persson
no flags Details | Diff

  None (edit)
Description Björn Persson 2007-09-02 21:09:40 EDT
Description of problem:
On some of the networks I connect my laptop to, the DHCP server provides an NTP
server address. On others it doesn't. When an NTP server is provided,
dhclient-script erases the servers I've configured manually from ntp.conf. The
old configuration is stored in ntp.conf.predhclient and is meant to be restored
when disconnecting, but this approach is inherently unreliable. The restoration
might not happen because DHclient gets killed or Linux crashes or for any number
of other reasons. The next time I connect, dhclient-script copies its own
version of ntp.conf to ntp.conf.predhclient, overwriting the last trace of the
manually configured servers. Then when I connect to a network without a
DHCP-provided NTP server, I suddenly have no reachable NTP server at all.

Version-Release number of selected component (if applicable):
dhclient-3.0.5-38.fc7

Expected results:
dhclient-script should add and remove only DHCP-provided NTP servers and leave
the manually configured ones in place. The attached patch makes it so.
Comment 1 Björn Persson 2007-09-02 21:09:40 EDT
Created attachment 184921 [details]
makes dhclient-script manage its own lines and leave others alone
Comment 2 David Cantrell 2007-09-03 02:28:10 EDT
Please submit the patch in unified diff format (diff -u).  Thanks.
Comment 3 Björn Persson 2007-09-03 05:15:29 EDT
Created attachment 185151 [details]
makes dhclient-script manage its own lines and leave others alone – unified diff
Comment 4 David Cantrell 2007-09-04 12:09:12 EDT
I've patched dhclient-script in Fedora 7 and rawhide.  An updates package is
available in the updates testing collection for F-7 now.

Thanks.
Comment 5 Fedora Update System 2007-09-04 18:07:29 EDT
dhcp-3.0.5-39.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2007-09-12 12:43:01 EDT
dhcp-3.0.5-39.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.