Bug 274771 - Unnecessary __find_requires
Unnecessary __find_requires
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ntp (Show other bugs)
rawhide
All All
medium Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-02 21:18 EDT by Robert Scheck
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 10:46:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2007-09-02 21:18:50 EDT
Description of problem:
__find_requires within ntp.spec is IMHO absolutely unnecessary. The package 
provides /usr/sbin/ntp-wait which requires /usr/bin/perl so why the hell do
you strip these requirements? This looks very odd to me.

Version-Release number of selected component (if applicable):
ntp-4.2.4p2-5

Actual results:
Unnecessary __find_requires

Expected results:
No __find_requires any longer
Comment 1 Miroslav Lichvar 2007-09-03 08:14:39 EDT
Looks like a fix for bug #111227.

Ok, it will be dropped in the next release. ntptrace has been also rewritten, so
we have now two utilities in the package that require perl.
Comment 2 Robert Scheck 2007-09-03 08:25:52 EDT
It isn't a fix to bug #111227. That guy expects what IMHO current behaviour 
is, but from the packaging aspect his wish is wrong. But thanks for dropping 
it.
Comment 3 Miroslav Lichvar 2007-09-24 10:46:06 EDT
Fixed in ntp-4.2.4p2-6.fc8.

Note You need to log in before you can comment on or make changes to this bug.