Bug 27509 - Sound doesnt work on Dell Inspiron 3500 (NM256)
Sound doesnt work on Dell Inspiron 3500 (NM256)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Pete Zaitcev
Brock Organ
:
: 28510 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-14 00:47 EST by Chris Chabot
Modified: 2007-04-18 12:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-14 16:07:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Chabot 2001-02-14 00:47:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-ac11 i686)


Sound driver module for the NeoMagic AV 256 refuses to load.
Tried the driver that worked under redhat 6 & 7 (opl3sa2), and tried nm256
both report :
	no cards found, please specify io/dma/dma2/ms_io
(yes i have the params set in /etc/modules.conf, and i double checked these
params in redhat 7.0 where it works)
after doing a modprobe sound (aliased to opl3sa2) dmesg reports:
opl3sa2: Controll I/O port 0x0 not free

the port specified in modules.conf is 0x220 (what its set to in the bios)


Reproducible: Always
Steps to Reproduce:
1. Get a dell inspiron 3500
2. alias sound opl3sa2
3. options opl3sa2 io=0x... etc
4. modprobe sound
	

Expected Results:  sound driver shouldve loaded


Tried both rh 7.1 supplied kernel 2.4.0 and self compiled 2.4.1 and
2.4.1ac11, all share the same result, presumably a 2.4 kernel bug
Comment 1 Michael K. Johnson 2001-02-14 10:39:13 EST
Arjan, do you know if this is fixed in later kernels?
Comment 2 Bill Nottingham 2001-02-14 12:26:57 EST
What happens if you add 'isapnp=0' to the options for opl3sa2?
Comment 3 Arjan van de Ven 2001-02-14 12:29:28 EST
as far as I can see the ac11 opl3sa driver is latest, and that didn't work
Comment 4 Arjan van de Ven 2001-02-14 13:32:04 EST
Can you give me the output of both "lspci" and "lspci -v" ?
The nm256 driver expects a PCI driver and the PCI ID might be missing.
Comment 5 Glen Foster 2001-02-15 18:09:05 EST
We (Red Hat) should really try to resolve this before next release.
Comment 6 Chris Chabot 2001-02-15 23:39:16 EST
notting@redhat.com:
using isapnp=0 doesnt aliviate the problem.
only gives the error 'param_isapnp' invalid param when loading the module.

arjanv@redhat.com:
the output for lspci/lspci -v listed below
00:00.0 Host bridge: Intel Corporation 440BX/ZX - 82443BX/ZX Host bridge (rev
03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX - 82443BX/ZX AGP bridge (rev 03)
00:04.0 CardBus bridge: Texas Instruments PCI1220 (rev 02)
00:04.1 CardBus bridge: Texas Instruments PCI1220 (rev 02)
00:07.0 Bridge: Intel Corporation 82371AB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB PIIX4 ACPI (rev 02)
01:00.0 VGA compatible controller: Neomagic Corporation [MagicMedia 256AV] (rev
12)
01:00.1 Multimedia audio controller: Neomagic Corporation [MagicMedia 256AV
Audio] (rev 12)
00:00.0 Host bridge: Intel Corporation 440BX/ZX - 82443BX/ZX Host bridge (rev
03)
        Flags: bus master, medium devsel, latency 64
        Memory at e0000000 (32-bit, prefetchable) [size=64M]
        Capabilities: [a0] AGP version 1.0

00:01.0 PCI bridge: Intel Corporation 440BX/ZX - 82443BX/ZX AGP bridge (rev 03)
(prog-if 00 [Normal decode])
        Flags: bus master, 66Mhz, medium devsel, latency 128
        Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
        Memory behind bridge: fe700000-fecfffff
        Prefetchable memory behind bridge: fd000000-fe3fffff

00:04.0 CardBus bridge: Texas Instruments PCI1220 (rev 02)
        Subsystem: Dell Computer Corporation: Unknown device 008f
        Flags: bus master, medium devsel, latency 168, IRQ 10
        Memory at 10000000 (32-bit, non-prefetchable) [size=4K]
        Bus: primary=00, secondary=02, subordinate=02, sec-latency=176
        Memory window 0: 10400000-107ff000 (prefetchable)
        Memory window 1: 10800000-10bff000
        I/O window 0: 00001000-000010ff
        I/O window 1: 00001400-000014ff
        16-bit legacy interface ports at 0001

00:04.1 CardBus bridge: Texas Instruments PCI1220 (rev 02)
        Subsystem: Dell Computer Corporation: Unknown device 008f
        Flags: bus master, medium devsel, latency 168, IRQ 10
        Memory at 10001000 (32-bit, non-prefetchable) [size=4K]
        Bus: primary=00, secondary=06, subordinate=06, sec-latency=176
        Memory window 0: 10c00000-10fff000 (prefetchable)
        Memory window 1: 11000000-113ff000
        I/O window 0: 00001800-000018ff
        I/O window 1: 00001c00-00001cff
        16-bit legacy interface ports at 0001

00:07.0 Bridge: Intel Corporation 82371AB PIIX4 ISA (rev 02)
        Flags: bus master, medium devsel, latency 0

00:07.1 IDE interface: Intel Corporation 82371AB PIIX4 IDE (rev 01) (prog-if 80
[Master])
        Flags: bus master, medium devsel, latency 64
        I/O ports at fcd0 [size=16]

00:07.2 USB Controller: Intel Corporation 82371AB PIIX4 USB (rev 01) (prog-if 00
[UHCI])
        Flags: bus master, medium devsel, latency 64, IRQ 11
        I/O ports at fce0 [size=32]

00:07.3 Bridge: Intel Corporation 82371AB PIIX4 ACPI (rev 02)
        Flags: medium devsel, IRQ 9

01:00.0 VGA compatible controller: Neomagic Corporation [MagicMedia 256AV] (rev
12) (prog-if 00 [VGA])
        Subsystem: Dell Computer Corporation: Unknown device 008f
        Flags: bus master, fast Back2Back, medium devsel, latency 128
        Memory at fd000000 (32-bit, prefetchable) [size=16M]
        Memory at fe800000 (32-bit, non-prefetchable) [size=4M]
        Memory at fec00000 (32-bit, non-prefetchable) [size=1M]
        Capabilities: [dc] Power Management version 1

01:00.1 Multimedia audio controller: Neomagic Corporation [MagicMedia 256AV
Audio] (rev 12)
        Subsystem: Dell Computer Corporation MagicMedia 256AV Audio Device on
Colorado Inspiron
        Flags: fast Back2Back, medium devsel, IRQ 11
        Memory at fe000000 (32-bit, prefetchable) [size=4M]
        Memory at fe700000 (32-bit, non-prefetchable) [size=1M]
        Capabilities: [dc] Power Management version 1

Comment 7 Michael K. Johnson 2001-02-28 22:50:04 EST
Pete, related to the other opl3 bugs you are looking at?
Comment 8 Trond Eivind Glomsrxd 2001-03-09 14:34:34 EST
Happens on my I3500 as well, I'll bring it in.
Comment 9 David Sainty 2001-03-10 15:03:50 EST
HW: Dell Latitude LS500 + NeoMagic 256AV
SW: wolverine upgraded to rawhide-20010303 + kernel-2.4.2-0.1.22 + latest kudzu,
sndconfig, etc.

sndconfig-0.64.3-1 now says that NeoMagic sound (which is autodetected) is not
currently supported.

Doing a "modprobe nm256_audio" always freezes the machine, even if we don't
start X first and don't use frame buffer mode. (I was testing for any connection
with the video on the chip).

Doing a "modprobe opl3sa2" gave:

opl3sa2           7824   0  (unused)
ad1848           17904   0  [opl3sa2]
mpu401           19664   0  [opl3sa2]
sound            62704   0  [opl3sa2 ad1848 mpu401]
sountcore         4400   2  [sound]

Excerpt from /proc/pci:

Bus  1, device   0, function  1:
  Multimedia audio controller: Neomagic Corporation [MagicMedia 256AV Audio]
(rev 32).
    IRQ 10.
    Prefetchable 32 bit memory at 0xf7800000 [0xf7bfffff]
    Non-prefetchable 32 bit memory at 0xfea00000 [0xfeafffff].

Am happy to test any patches or provide more info.
Comment 10 Trond Eivind Glomsrxd 2001-03-14 16:07:31 EST
When adding the opl3sa2 parameter on 2.4.2-0.1.28, I get this in dmesg:

ad1848/cs4248 codec driver <....>
opl3sa2: Control I/O port 0x0 not free
Comment 11 Trond Eivind Glomsrxd 2001-03-14 18:01:16 EST
Bill did a little magic, and came up with these parameters for 2.4 on my machine
(the actual values depend on your configuration):

options sound-slot-0 ad1848
options sound dmabuf=1
alias synth0 opl3
options opl3 io=0x388
options ad1848 io=0x530 irq=5 dma=0 dma2=1
Comment 12 Trond Eivind Glomsrxd 2001-03-29 15:22:52 EST
It's even added to sndconfig now...
Comment 13 Trond Eivind Glomsrxd 2001-03-29 15:23:08 EST
*** Bug 28510 has been marked as a duplicate of this bug. ***
Comment 14 Yaron Minsky 2001-04-17 17:01:48 EDT
I'm not sure how this one got resolved, but I just upgraded to RedHat 7.1, and
my soundcard doesn't work anymore, much as described above.  I'm using a Gateway
solo 2500 with a Neomagic MagicWave 256AV soundcard.  Sndconfig was unable to
configure the sound correctly.  After much futzing, I finally put in the
following parameters from a previous post:

options sound-slot-0 ad1848
options sound dmabuf=1
alias synth0 opl3
options opl3 io=0x388
options ad1848 io=0x530 irq=5 dma=0 dma2=1

That worked.  But ugh, this is not a good way for the sound setup to work.  Most
users aren't going to go pawing through bugzilla....
Comment 15 Pete Zaitcev 2001-04-17 17:11:56 EDT
The bug was resolved by teg, he added that modules.conf
snippet on 3/14/2001 and wrote "It's even added to sndconfig now",
but he forgot to place a sndconfig dash number there.

When I see "I just upgraded to RedHat 7.1", I get highly
suspicious. Perhaps sndconfig was not properly updated
by the upgrade process.
Comment 16 Yaron Minsky 2001-04-18 11:25:03 EDT
I checked my local sndconfig installation, and I'm running version
sndconfig-0.64.8-1, which is the version shipped with RH7.1. rpm -V doesn't show
any modifications.  So the upgrade from 7.0->7.1 seems to have upgraded
sndconfig appropriately.
Comment 17 dkaplan 2001-06-11 19:36:15 EDT
 I have a gateway 2500 and have had a lot of similiar, but somehow distinct,
problems using sndconfig to configure sound on my machine.  I did the upgrade
(or downgrade, depending on how you look at it) from 7.0 to 7.1 and suddenly my
sound stopped working.  At first sndconfig just seg faulted, so I got the
sndconfig-0.64.9-1.i386.rpm from Rawhide.  This didnt seg fault but it did
say that it had trouble openning /dev/audio.  

My modules.conf has always had lines similar to the following for sound
configuration:

alias sound-slot-0 opl3sa2
options sound dmabuf=1
alias synth0 opl3
options opl3 io=0x388
options opl3sa2 mss_io=0x530 irq=5 dma=0 dma2=1 mpu_io=0x330 io=0x370 isapnp=0

(I added the isapnp=0 as suggested above, but it didnt help).

The sound devices have the following permissions:

crw-------    1 dmk      root      14,   4 Mar 23 20:38 /dev/audio
crw-------    1 dmk      root      14,   3 Mar 23 20:38 /dev/dsp
crw-------    1 dmk      root      14,   0 Mar 23 20:38 /dev/mixer

Upon intenting sndconfig, I get the following messages in /var/log/messages:

Jun 11 15:58:41 volcan kernel: opl3sa2: No cards found
Jun 11 15:58:41 volcan kernel: opl3sa2: 0 PnP card(s) found.
Jun 11 15:58:41 volcan modprobe: Note: /etc/modules.conf is more recent than
/lib/modules/2.4.2-2/modules.dep
Jun 11 15:58:41 volcan modprobe: Note: /etc/modules.conf is more recent than
/lib/modules/2.4.2-2/modules.dep
Jun 11 15:58:41 volcan modprobe: modprobe: Can't locate module sound-service-0-0
Jun 11 15:58:41 volcan modprobe: Note: /etc/modules.conf is more recent than
/lib/modules/2.4.2-2/modules.dep
Jun 11 15:58:41 volcan modprobe: Note: /etc/modules.conf is more recent than
/lib/modules/2.4.2-2/modules.dep
Jun 11 15:58:41 volcan modprobe: modprobe: Can't locate module sound-service-0-3

Also, I at some point had files like /etc/rc.d/init.d/sound, but these have
disappeared.  I assume this isnt important?!?!

I made the changes in my modules.conf as suggested above.  It now reads:

options sound-slot-0 ad1848
options sound dmabuf=1
alias synth0 opl3
options opl3 io=0x388
options ad1848 io=0x530 irq=5 dma=0 dma2=1

This sort of worked in that I now have some sort of sound, but everything
repeats itself or gets cut off.  This seems like a problem I had way in the
beginning, but I cant remember how i resolved it.

If anyone can give me a hand with this, that would be great.

Note You need to log in before you can comment on or make changes to this bug.