Bug 27510 - Installer running in text mode got through most of the install and prodcued this error:
Installer running in text mode got through most of the install and prodcued t...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-14 00:47 EST by Alan Hoiland
Modified: 2007-04-18 12:31 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-15 12:50:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump file (959 bytes, text/plain)
2001-02-14 00:48 EST, Alan Hoiland
no flags Details

  None (edit)
Description Alan Hoiland 2001-02-14 00:47:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1632, in 
doInstall
    self.writeConfiguration ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1378, in 
writeConfiguration
    self.writeLanguage ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 471, in 
writeLanguage
    f.close()
IOError: [Errno 5] Input/output error

Local variables in innermost frame:
f: <closed file '/mnt/sysimage/etc/sysconfig/i18n', mode 'w' at 8fc2ec0>
self: <todo.ToDo instance at 82691f8>

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>


Reproducible: Didn't try
Steps to Reproduce:
1.Start the install
2.Choose text install
3.Choose Gnome and games
4.Accept default settings
5.Setup almost finishes but produces this error
Comment 1 Alan Hoiland 2001-02-14 00:48:18 EST
Created attachment 9981 [details]
dump file
Comment 2 Alan Hoiland 2001-02-14 10:35:58 EST
I did try the install again with similar results.  It seems like it did not get 
as far in the install before abending, but it did produce the same error.
Comment 3 Matt Wilson 2001-02-14 13:26:44 EST
switch to Alt+F2 and attach the output of "df"
Comment 4 Alan Hoiland 2001-02-14 13:34:32 EST
What do you mean by "switch to Alt+F2 and attach the output of "df""?  Do you 
mean when the error screen appears press Alt+F2?  Will I see a new screen?  
Will DF become obvious?
Comment 5 Matt Wilson 2001-02-14 13:38:49 EST
Alt+F2 gives you a shell prompt.  The df command will show you the disk space
free on all mounted volumes.
Comment 6 Matt Wilson 2001-02-14 13:39:23 EST
(yes, do this when the error window appears)
Comment 7 Alan Hoiland 2001-02-15 12:50:42 EST
It appears I had a hardware problem!  I tried to install Red Hat again and this 
time it chugged for a _long_ time and completed the install.  But everytime I 
tried to boot, I got CRC and other I/O errors.  I swapped in a different hard 
drive and had completely different results.  The install went well and I can 
now access the system.

Thanks for your help!

Note You need to log in before you can comment on or make changes to this bug.