Bug 27512 - Unloading bonding driver panics kernel
Summary: Unloading bonding driver panics kernel
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Miller
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-02-14 05:52 UTC by Chris Chabot
Modified: 2007-04-18 16:31 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-15 23:09:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Chabot 2001-02-14 05:52:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-ac11 i686)


when using the bonding driver supplied in the 2.4 kernel (bonding.o) to
bond 2 network cards, redhat (ie kernel) crashes on system shutdown (when
unloading the driver)

Tried this on both rh 7.1 supplied kernel (normal,smp,enterprise) and on a
self compiled vanilla 2.4.1 kernel, they have the same bug

Tested on a SMP dual p3 600, with 2x 3c905B network cards.
/etc/modules.conf contains alias bond0 bonding
ifcfg-eth0 & eth1 are configured for master=bond0 slave=yes

bonding driver loads perfectly, and functions perfectly, but crashes on
system poweroff/shutdown. This is causing me a lot of fsck's since it cant
shut down normaly


Reproducible: Always
Steps to Reproduce:
1. setup a bond0 device
2. ifdown bond0
3. ifdown eth0 (or 1)
*crash and burn*

Also reproducable by doing 'poweroff' or 'shutdown'
	

Expected Results:  bring down interface.

Comment 1 Michael K. Johnson 2001-02-14 15:41:37 UTC
Alan, has this been fixed in any of your -ac releases?

Comment 2 Glen Foster 2001-02-15 23:09:01 UTC
We (Red Hat) should really try to resolve this before next release.

Comment 3 Michael K. Johnson 2001-03-01 04:55:24 UTC
This is fixed in our latest rawhide kernel.


Note You need to log in before you can comment on or make changes to this bug.