Bug 275681 - CBQ support broken in 2.6.22.4-65.fc7 i386? (/sbin/modprobe sch_cbq returns "Key was rejected by service")
CBQ support broken in 2.6.22.4-65.fc7 i386? (/sbin/modprobe sch_cbq returns ...
Status: CLOSED DUPLICATE of bug 295581
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-03 20:47 EDT by Jan Andrejkovic
Modified: 2011-05-14 12:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 07:02:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Andrejkovic 2007-09-03 20:47:25 EDT
Description of problem:

It seems this kernel version has broken cbq support...

Version-Release number of selected component (if applicable):

Kernel version: 2.6.22.4-65.fc7

How reproducible:


Steps to Reproduce:
1. 
# /sbin/cbq start
FATAL: Error inserting sch_cbq
(/lib/modules/2.6.22.4-65.fc7/kernel/net/sched/sch_cbq.ko): Key was rejected by
service

2. or:
# /sbin/modprobe sch_cbq
FATAL: Error inserting sch_cbq
(/lib/modules/2.6.22.4-65.fc7/kernel/net/sched/sch_cbq.ko): Key was rejected by
service

Actual results:
"Key was rejected by service"

Expected results:
no error

Additional info:
- Info in logs: "Module signature verification failed"
- My CPU: VIA Esther C7
- It seems it is working fine for x86_64
Comment 1 Jan Andrejkovic 2007-09-14 20:17:32 EDT
Hello,

I upgraded the kernel yesterday to 2.6.22.5-76.fc7 but as it seems I have still
tha same problem:

# /sbin/modprobe sch-cbq
FATAL: Error inserting sch_cbq
(/lib/modules/2.6.22.5-76.fc7/kernel/net/sched/sch_cbq.ko): Key was rejected by
service...

(In reply to comment #0)
> Description of problem:
> 
> It seems this kernel version has broken cbq support...
> 
> Version-Release number of selected component (if applicable):
> 
> Kernel version: 2.6.22.4-65.fc7
> 
> How reproducible:
> 
> 
> Steps to Reproduce:
> 1. 
> # /sbin/cbq start
> FATAL: Error inserting sch_cbq
> (/lib/modules/2.6.22.4-65.fc7/kernel/net/sched/sch_cbq.ko): Key was rejected by
> service
> 
> 2. or:
> # /sbin/modprobe sch_cbq
> FATAL: Error inserting sch_cbq
> (/lib/modules/2.6.22.4-65.fc7/kernel/net/sched/sch_cbq.ko): Key was rejected by
> service
> 
> Actual results:
> "Key was rejected by service"
> 
> Expected results:
> no error
> 
> Additional info:
> - Info in logs: "Module signature verification failed"
> - My CPU: VIA Esther C7
> - It seems it is working fine for x86_64

Comment 2 Jan Andrejkovic 2007-09-17 07:04:03 EDT
As it seems my box has some problem and somehow I cannot load any additional 
module, however they are loaded fine during the startup process...

I will investigate why this happened. But this is definetely not CBQ problem.

Jan
Comment 3 Chuck Ebbert 2007-09-19 14:33:39 EDT
This happens when the padlock-sha module is loaded. Marking this as a dup of the
newer bug since that one has more information...

*** This bug has been marked as a duplicate of 295581 ***

Note You need to log in before you can comment on or make changes to this bug.