Bug 275861 - rmdir -v always writes to stderr whether or not there is an error
rmdir -v always writes to stderr whether or not there is an error
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: coreutils (Show other bugs)
4.5
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-04 05:24 EDT by Rainer Traut
Modified: 2008-06-16 07:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-16 07:33:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rainer Traut 2007-09-04 05:24:19 EDT
Description of problem:
rmdir -v writes status messages to stderr

Version-Release number of selected component (if applicable):
coreutils-5.2.1-31.6

How reproducible:
always

Steps to Reproduce:
1. 
[tr@server bin]$ cd /tmp
[tr@server tmp]$ mkdir myDir
[tr@server tmp]$ rmdir -v myDir/ 2>/dev/null
[tr@server tmp]$ mkdir myDir
[tr@server tmp]$ rmdir -v myDir/ 1>/dev/null
rmdir: Verzeichnis wird entfernt, myDir/
[tr@server tmp]$ 

2.
3.
  
Actual results:
[tr@server tmp]$ rmdir -v myDir/ 1>/dev/null
rmdir: Verzeichnis wird entfernt, myDir/

This output is wrong, the directory gets deleted without error.

Expected results:
rmdir -v output to stdout.

Additional info:
THe issue is on EL3 as well, I have not tested on EL5 though.
Comment 1 Ondrej Vasik 2008-02-28 10:51:39 EST
Thanks for report, it is not only rmdir ... actually there are more GNU
coreutils utilities which provide diagnostics on stderr. Upstream recently
accepted the patch for split and mkdir, so I will check the rest (sometimes it
can't be redirected to stdout like in case of shred) and will do update at least
for Fedora. Anyway - I have to think a bit about possible impact of doing that
change in RHELs because it could break some scripts. 
Comment 2 Ondrej Vasik 2008-06-16 07:33:54 EDT
Closing NEXTRELEASE as it could have impact on some scripts and is just cosmetic
thing. Feel free to contact Red Hat Enterprise Linux product support if you wish
to have it fixed for RHEL-4 or RHEL-5. Proposed behaviour (for more utilities)
was  accepted by upstream and is part of latest Fedoras.

Note You need to log in before you can comment on or make changes to this bug.