Bug 27651 - PDF's not served correctly via the Web and securewebserver using apache 1.3.14
PDF's not served correctly via the Web and securewebserver using apache 1.3.14
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
http://www.icsc.org/srch/rsrch/econst...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-14 15:05 EST by Brett Allen Hansen
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 06:30:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brett Allen Hansen 2001-02-14 15:05:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; DigExt)


Apache Version > 1.3.12 and < 1.3.17 has issues serving PDF files 
correctly on a regular basis.  The PDF files stop part way though the 
download, sometimes binary code is displaied to the screen, etc.

Reproducible: Always
Steps to Reproduce:
1. Visit Above URL with Red Hats Secure Web Server Using Apache 1.3.14
2.
3.
	

Actual Results:  Garbage, or partly served PDF files display

Expected Results:  Fully displaied PDF Files

Note From Apache's Web Site On Bug Fixes On Apache 1.3.17: 
Correct handling of request byte ranges as specified by RFC 2616. 

Note From Geocrawler's News Archives at:
http://www.geocrawler.com/archives/3/192/2000/10//4583631/

----------
We have put support calls to Adobie and tried everything they suggested.  
We have tested this bug on the early versions of Apache and there is no 
issue.  (enviorment variable from Linux: SERVER_SOFTWARE=Red Hat 
Secure/2.0 (Unix) mod_ssl/2.0.7 SSLeay/0.9.0b) but with the newest Secure 
Web server we have issues (enviorment variable from Linux: 
SERVER_SOFTWARE=Apache/1.3.14 (Unix) Red-Hat-Secure/3.2.2 mod_ssl/2.7.1 
BSAFE-SSL-C/1.0.0i)
Comment 1 Brett Allen Hansen 2001-02-16 11:06:58 EST
We just installed Apache 1.3.17 from source with SSL Support and our issue went 
away.  We would like to use RedHat's secure web server tho.  An upgrade would 
be great

-Brett
Comment 2 Eric Jon Rostetter 2002-07-30 16:05:21 EDT
This problem was gone with secureweb-3.2.* up until secureweb-3.2.6-1 which
re-introduced it.  Appears to be in 3.2.6-1 and 3.2.7-1.  Really need a fix.
Any plans to fix this?  Or must I just dump RH 6.x and secureweb server???
Comment 3 Joe Orton 2004-09-21 06:30:58 EDT
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.

Comment 4 Joe Orton 2004-09-21 06:39:01 EDT
Thanks for the report.  This is a mass bug update; since this release
of Red Hat Linux is no longer supported, please either:

a) try and reproduce the bug with a supported version of Red Hat
Enterprise Linux or Fedora Core, and re-open this bug as appropriate
after changing the Product field, or,

b) if relevant, try and reproduce this bug using the current version
of the upstream package, and report the bug upstream.


Note You need to log in before you can comment on or make changes to this bug.