Bug 276521 - [RFE] please apply qt-copy patches 0079 and 0080
[RFE] please apply qt-copy patches 0079 and 0080
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-04 11:41 EDT by drago01
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-04 09:44:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description drago01 2007-09-04 11:41:26 EDT
The qt-copy patches 0079 and 0080 located at: 
http://websvn.kde.org/branches/qt/3.3/qt-copy/patches/
Fix two composite related problems with qt apps:
1) 
the 0079 one sets window type hints for override_redirect windows (menus,
tooltips, ...) so compiz can properly match them (it isn't needed for
non-compositing window managers because those don't draw override_redirect windows)
2) 
the 0080 makes Qt support the _NET_WM_SYNC_REQUEST protocol (from the commit
description: "Support _NET_WM_SYNC_REQUEST (less flicker during resize and with
compositing also when opening a window).")

Please consider appling this patches to the fedora package to improve the user
experience with compiz (compisted desktop in general) while using qt apps.
Comment 1 Danny Baumann 2007-10-02 11:50:14 EDT
Please also consider applying the 0084 one. The reason is the same as for the
0079 one: Without this patch, compiz can't properly match the menus and tooltips
for KDE applications.
Comment 2 Rex Dieter 2007-10-02 12:44:49 EDT
Than, ping?
Comment 3 Ngo Than 2007-10-04 09:44:26 EDT
it's fixed in CVS and will be available in rawhide soon

Note You need to log in before you can comment on or make changes to this bug.