Bug 277651 - Yum/Software Updater Crash/Dump (Header is not complete)
Yum/Software Updater Crash/Dump (Header is not complete)
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum-rhn-plugin (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Clifford Perry
Depends On:
  Show dependency treegraph
Reported: 2007-09-04 21:32 EDT by paulp
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-02 10:00:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Software Updater crash dump (1.64 KB, text/plain)
2007-09-04 21:32 EDT, paulp
no flags Details

  None (edit)
Description paulp 2007-09-04 21:32:33 EDT
Description of problem:
When trying to update my packages with "software updater" it crashes

Version-Release number of selected component (if applicable):

How reproducible:
yum also crashes from a terminal

Steps to Reproduce:
1. Applications -> System Tools -> Software Updater
2. Click on "Apply updates"
Actual results:
the attached crash dump

Expected results:
no crash - all packages updated from RHN successfully

Additional info:
Comment 1 paulp 2007-09-04 21:32:33 EDT
Created attachment 186781 [details]
Software Updater crash dump
Comment 2 paulp 2007-09-04 21:36:54 EDT
# yum update
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
Setting up Update Process
Setting up repositories
rhel-i386-server-5        100% |=========================| 1.4 kB    00:00     
rhel-i386-server-vt-5     100% |=========================| 1.4 kB    00:00     
rhn-tools-rhel-i386-serve 100% |=========================| 1.2 kB    00:00     
Reading repository metadata in from local files
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for vim-minimal to pack into transaction set.
vim-minimal-7.0.109-3.el5 100% |=========================|  591 B    00:00     
Error: failed to retrieve getPackage/vim-minimal-7.0.109-3.el5.3.i386.rpm from
error was [Errno -1] Header is not complete.
Comment 3 Red Hat Bugzilla 2007-10-25 20:53:22 EDT
User jslagle@redhat.com's account has been closed
Comment 4 paulp 2007-10-28 19:41:56 EDT
This bug was resolved by upgrading the upline RHN Proxy server from v4.1 to v4.2

This error was only present on RHEL5 hosts trying to update via the proxy 
server (all earlier versions of RHEL still worked).
Comment 5 Clifford Perry 2007-11-02 10:00:02 EDT
since RHN Proxy 4.1 does not support RHEL 5 yum clients, I have to say that this
is not a bug, by fact that your comment #4 confirms upgrade to 4.2 RHN Proxy
resolved the issue. I am closing as NOTABUG. Please re-open if you feel I miss
read this and that there is a specific other bug here with steps to reproduce. 


Note You need to log in before you can comment on or make changes to this bug.