Bug 27770 - Locale problems glibc/XFree
Locale problems glibc/XFree
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
All Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-15 05:35 EST by Kjartan Maraas
Modified: 2005-10-31 17:00 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-12 10:59:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Kjartan Maraas 2001-02-15 05:35:19 EST
There are conflicting definitions for Norwegian (nynorsk) in XFree's 
locale.alias and the one from glibc.

XFree uses "no@nynorsk              no_NO.ISO8859-1"
and        "no@nynorsk              ny_NO.ISO8859-1"

glibc uses "nynorsk                 nn_NO.ISO-8859-1"

The latter also has two different Norwegian (bokmel) entries:
           "nb_NO                   no_NO.ISO-8859-1"
           "norwegian               no_NO.ISO-8859-1"

On the whole there seems to be some confusion here.

GNOME uses nn_NO and KDE uses ny_NO. The latter is not
in any iso standard but seems to have been chosen randomly. Maybe an 
effort to make both use one definition that is in the iso standard would 
be a good thing.

Cheers
Kjartan Maraas
Comment 1 Glen Foster 2001-02-15 20:07:32 EST
This defect is considered MUST-FIX for Florence Release-Candidate #2
Comment 2 Mike A. Harris 2001-02-18 00:41:46 EST
Being unfamiliar with locale settings, what is he preferred correct fix?

Jakub, you're likely much more familiar with this and all locale problems
than I.  Can you help with this?
Comment 3 Kjartan Maraas 2001-02-18 03:41:36 EST
I sent a request to no@li.org to see if we could clear this once and for all.
The only answer I got was the following from Kjetil Torgrim Homme
<kjetilho@ifi.uio.no>:
------------------------------
"My view:

Braces -> Optional.

Using old language code:
no[_NO][.ISO8859-1][@bokmal]
no[_NO][.ISO8859-1]@nynorsk

Using the new language codes:
nb[_NO][.ISO8859-1]
nn[_NO][.ISO8859-1]

The latter is the future, but I think the old should work
(through libc-magic?) for compatability with other systems.
Esp. for the bokmel users."
-------------------------------

I agree with him and will work to make sure at least the translations I'm
responsible for (GNOME, Red Hat) move away from the deprecated codes. I'll also
try mailing the KDE people to see what their view on the matter is.

Comment 4 Trond Eivind Glomsrxd 2001-03-08 23:04:58 EST
I need to look it up... the switch for nynorsk should be a safe bet (the one KDE
has is definitely bogus), but I'm not sure about moving no to nb. My current
option is to use the glibc locale definititions as the guide line.
Comment 5 Jakub Jelinek 2001-03-12 07:51:42 EST
I believe we should use nb_NO and ny_NO everywhere, the thing is that glibc
ATM unfortunately lacks a nb_NO locale definition and so for now aliases
nb_NO to no_NO. I have no idea what the difference between nynorsk and bokmal
is, so this is about all I can say to this.
Comment 6 Kjartan Maraas 2001-03-12 08:09:14 EST
The problem with "ny" is that it isn't in any standard. "nn" on the other hand
is. I talked to the KDE translator and he was all for changing "ny" to "nn". The
KDE people just started using ny since nothing else was established as a norm I
think.

Kjartan
Comment 7 Jakub Jelinek 2001-03-12 08:18:10 EST
Oops, typo, s/ny_NO/nn_NO/ in my last submition.
Comment 8 Trond Eivind Glomsrxd 2001-03-12 10:59:08 EST
nb_NO is identical to no_NO - it's Norwegian as used by 90% of the population.

"Nynorsk" is a language constructed in the late 19th century from "untarnished"
dialects, and is currently used by 10% (and dropping)  - it's very similar to
standard Norwegian (which they prefer to call "bokmaal", as in "book language").
The words are slighly different, and the grammar (mostly plural endings, but
also sentence construction) also differs a little bit. There are usullay no
problems understanding the one your not using yourself.

Using "no_NO" for Norwegian (bokmaal) and "nn_NO" for Nynorsk sounds like the
best thing to do right now - in X and KDE as well.
Comment 9 Mike A. Harris 2001-03-15 15:21:08 EST
Fixed in Rawhide 4.0.2a

Note You need to log in before you can comment on or make changes to this bug.