Bug 277761 - util-linux-2.13-0.44.el5.src.rpm cannot be built correctly because there is a mistake in util-linux.spec
util-linux-2.13-0.44.el5.src.rpm cannot be built correctly because there is a...
Status: CLOSED DUPLICATE of bug 234303
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: util-linux (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-05 02:01 EDT by Yu Zhiguo
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-18 04:05:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the patch (257 bytes, patch)
2007-09-05 02:01 EDT, Yu Zhiguo
no flags Details | Diff

  None (edit)
Description Yu Zhiguo 2007-09-05 02:01:41 EDT
Description of problem:
util-linux-2.13-0.44.el5.src.rpm cannot be built correctly because there is a 
mistake in util-linux.spec.(the patches about raw device support will be used 
only the value of include_raw is 1)

Version-Release number of selected component (if applicable):
util-linux-2.13-0.44.el5.src.rpm

How reproducible:
100%

Steps to Reproduce:
1. #rpm -vih util-linux-2.13-0.44.el5.src.rpm
2. #cd /usr/src/redhat/
3. #rpmbuild -bp SPECS/util-linux.spec
  
Actual results:

conflict occurs and exit status is not 0
----------------------------------------------------------------
Patch #256 (util-linux-2.13-raw-raw0.patch):
+ patch -p1 -s
1 out of 2 hunks FAILED -- saving rejects to file disk-utils/raw.c.rej
error: Bad exit status from /var/tmp/rpm-tmp.87525 (%prep)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.87525 (%prep)
----------------------------------------------------------------

Expected results:
no conflict and exit status is 0

Additional info:
the content of patch
----------------------------------------------------------------
--- util-linux.spec.orig        2007-09-05 21:48:26.000000000 +0800
+++ util-linux.spec     2007-09-05 21:48:59.000000000 +0800
@@ -326,7 +326,9 @@
 %patch253 -p1
 %patch254 -p1
 %patch255 -p1
+%if %{include_raw}
 %patch256 -p1
+%endif
 %patch257 -p1
 %patch258 -p1
Comment 1 Yu Zhiguo 2007-09-05 02:01:41 EDT
Created attachment 186891 [details]
the patch
Comment 2 Karel Zak 2007-09-18 04:05:22 EDT
Fixed in RHEL5.1.

*** This bug has been marked as a duplicate of 234303 ***

Note You need to log in before you can comment on or make changes to this bug.