Bug 277981 - Failure message for named starting is overwritten at init time
Failure message for named starting is overwritten at init time
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-05 04:29 EDT by Quentin Armitage
Modified: 2013-04-30 19:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-05 06:03:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch file to stop overwriting of failure messages of startup of named (365 bytes, patch)
2007-09-05 04:29 EDT, Quentin Armitage
no flags Details | Diff

  None (edit)
Description Quentin Armitage 2007-09-05 04:29:53 EDT
Description of problem: Cannot see named failed to start when invoked by init


Version-Release number of selected component (if applicable):bind-9.5.0-11.a6.fc8


How reproducible:Always


Steps to Reproduce:
1.Boot system
2.
3.
  
Actual results:
Line "Starting named:       [FAILED]" gets overwritten

Expected results: Should be able to see "Starting named:     [FAILED]


Additional info:
Problem can also be seen simply by invoking /etc/init.d/named start, and occurs
when named fails to be started via the daemon function call.
For some reason on my system, named will not start when invoked by
/etc/init.d/named start, but if /etc/init.d/named is copied to
/etc/init.d/named.new, then /etc/init.d/named.new start works. I am still
investigating this.

A patch file is attached that moves the echo command to ensure that a new line
is emitted after a failure to start named.
Comment 1 Quentin Armitage 2007-09-05 04:29:53 EDT
Created attachment 187051 [details]
Patch file to stop overwriting of failure messages of startup of named
Comment 2 Adam Tkac 2007-09-05 04:43:49 EDT
Patch looks fine I will include it in next build. And about your problems (you
use /etc/init.d/named.new instead /etc/init.d/named) - do you have SELinux in
enforcing mode? Because if you start named with *.new I guess it has different
SELinux context.

Adam
Comment 3 Adam Tkac 2007-09-05 06:03:10 EDT
fixed in 9.5.0-11.3.a6

Note You need to log in before you can comment on or make changes to this bug.