Bug 278201 - gdm login problem with national characters
gdm login problem with national characters
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-09-05 07:09 EDT by Karl-Olov Serrander
Modified: 2008-06-07 05:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-18 14:40:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Karl-Olov Serrander 2007-09-05 07:09:28 EDT
Description of problem: GDM login failes when password contains 8-bit chars

Version-Release number of selected component (if applicable):

How reproducible: every time i have tested this. 
Usually running with LANG=en_US, but also tested with en_US.UTF-8 without any
difference. Local user.

Steps to Reproduce:
1. set password in console mode to kjh456ä (swedish keyb)
2. try to login on console, works ok
3. try to login through gdm, fails
Actual results:
Failed login

Expected results:
Successfull login

Additional info: I must use same LANG when setting passwd, as used during login
or it failes in console too. I think this worked in fc3 but after upgrade to fc6
people have begun to have problems with this
Comment 1 Ray Strode [halfline] 2007-09-05 11:55:37 EDT
If you set LANG=en_US.utf8 when setting the password and before typing the
password, does it work?
Comment 2 Karl-Olov Serrander 2007-09-06 02:34:19 EDT
Have set LANG=en_US.utf8 in /etc/sysconfig/i18n and rebooted. In console mode I
can set my passwd (kjh456ä) and login, but login through gdm still fails. I have
done the same earlier, as mentioned above, with en_US and en_US.UTF-8 and the
same result.
Comment 3 Mike A. Harris 2007-11-09 08:33:43 EST
This is probably caused by bug #372151
Comment 4 Ray Strode [halfline] 2008-03-18 14:40:37 EDT

We no longer support Fedora Core 6 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)

Note You need to log in before you can comment on or make changes to this bug.