Bug 278631 - kernel fails to boot due to missing module in initrd
Summary: kernel fails to boot due to missing module in initrd
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: rawhide
Hardware: i686
OS: Linux
medium
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-05 15:33 UTC by Jay Fenlason
Modified: 2014-08-31 23:28 UTC (History)
1 user (show)

Fixed In Version: 2.6.23-0.174.rc6.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 21:20:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jay Fenlason 2007-09-05 15:33:22 UTC
Description of problem:
With kernels later than kernel-2.6.23-0.142.rc3.git10.fc8 my machine fails to 
boot because the initrd does not contain modules for both disk controllers.  
Rerunning mkinitrd --with=ata_piix makes it boot again.

Version-Release number of selected component (if applicable):
Anything later than kernel-2.6.23-0.142.rc3.git10.fc8

How reproducible:
Always

Steps to Reproduce:
1.yum -y update kernel
2.reboot
3.
  
Actual results:
...
Scanning logical volumes
  Reading all physical volumes.  This may take a while...
  Found volume group "FenlasonRawhide" using metadata type lvm2
Activating logical volumes
  2 logical volume(s) in volume group "FenlasonRawhide" now active
  Volume group "VolGroup00" not found
Trying to resume from /dev/VolGroup00/rawhide_swap
Unable to access resume device (/dev/VolGroup00/rawhide_swap)
Creating root device.
Mounting root filesystem.
mount: could not find filesystem '/dev/root'
...

Expected results:
...
Scanning logical volumes                                                        
  Reading all physical volumes.  This may take a while...                       
  Found volume group "VolGroup00" using metadata type lvm2                      
  Found volume group "FenlasonRawhide" using metadata type lvm2                 
Activating logical volumes                                                      
  2 logical volume(s) in volume group "FenlasonRawhide" now active              
  2 logical volume(s) in volume group "VolGroup00" now active                   
Trying to resume from /dev/VolGroup00/rawhide_swap                              
No suspend signature on swap, not resuming.
...

Additional info:
fenlason-lab3.boston.devel.redhat.com

Comment 1 Chuck Ebbert 2007-09-05 22:22:43 UTC
Does mkinitrd -v give any useful information?



Comment 2 Jay Fenlason 2007-09-12 21:20:33 UTC
Fixed with later kernels, like 2.6.23-0.174.rc6.fc8


Note You need to log in before you can comment on or make changes to this bug.