Bug 278771 - Missing GLX_EXT_texture_from_pixmap on i945
Missing GLX_EXT_texture_from_pixmap on i945
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-05 12:28 EDT by Zack Cerza
Modified: 2008-04-04 00:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 00:35:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (18.90 KB, text/plain)
2007-12-22 02:03 EST, Charles R. Anderson
no flags Details

  None (edit)
Description Zack Cerza 2007-09-05 12:28:58 EDT
Description of problem:
Compiz bails with the following errors on my i945:

compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0


Version-Release number of selected component (if applicable):
compiz-0.5.2-9.0ec3ec.fc8
xorg-x11-drv-i810-2.1.1-3.fc8
Comment 1 Zack Cerza 2007-09-05 12:30:10 EDT
<ajax> zack: blah.  i blame krh.

:)
Comment 2 Bryn M. Reeves 2007-10-23 08:35:32 EDT
still broken in today's rawhide:

kernel-2.6.23.1-26.fc8
xorg-x11-drv-i810-2.1.1-7.fc8
compiz-0.6.0-2.fc8
Comment 3 Dennis Wagelaar 2007-12-17 13:07:57 EST
Same experience on Intel G965 chipset. It used to work on Fedora 7. I found the
following link:

http://lists.freedesktop.org/archives/xorg/2007-November/029905.html

GLX_EXT_texture_from_pixmap comes up for "server glx extensions", "client glx
extensions", but not for "GLX extensions".

Versions:
kernel-2.6.23.8-63.fc8
xorg-x11-drv-i810-2.1.1-7.fc8
compiz-0.6.2-3.fc8
Comment 4 Dennis Wagelaar 2007-12-19 05:41:05 EST
Correction on my last comment: the problem only occurs by starting compiz via
"compiz --replace" on the console. It does work via the Gnome Desktop Effects
panel, except that I get no window decorations.

This is described in bug # 290001 and the described workaround solves my problem.
Comment 5 Charles R. Anderson 2007-12-22 02:01:15 EST
Doesn't work from Gnome Desktop Effects for me, nor "compiz --replace".  I get
the same error message. I'm testing the Rawhide LiveCD i686 20071220 on a Lenovo
T61 with the Intel video card.  

kernel-2.6.24-0.118.rc5.git6.fc9
xorg-x11-drv-i810-2.2.0-2.fc9
compiz-0.6.2-4.fc9

Comment 6 Charles R. Anderson 2007-12-22 02:03:46 EST
Created attachment 290287 [details]
Xorg.0.log

Xorg.0.log for this video card:

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960
Integrated Graphics Controller (rev 0c) (prog-if 00 [VGA])
	Subsystem: Lenovo Unknown device 20b5
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Interrupt: pin A routed to IRQ 20
	Region 0: Memory at f8100000 (64-bit, non-prefetchable) [size=1M]
	Region 2: Memory at e0000000 (64-bit, prefetchable) [size=256M]
	Region 4: I/O ports at 1800 [size=8]
	Capabilities: [90] Message Signalled Interrupts: Mask- 64bit- Queue=0/0
Enable-
		Address: 00000000  Data: 0000
	Capabilities: [d0] Power Management version 3
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
		Bridge: PM- B3+
	Kernel modules: i915

00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated
Graphics Controller (rev 0c)
	Subsystem: Lenovo Unknown device 20b5
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort-
<MAbort- >SERR- <PERR- INTx-
	Latency: 0
	Region 0: Memory at f8200000 (64-bit, non-prefetchable) [size=1M]
	Capabilities: [d0] Power Management version 3
		Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA
PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=0 PME-
		Bridge: PM- B3+
Comment 7 Charles R. Anderson 2008-04-04 00:35:15 EDT
Works for me in current rawhide.  I'm pretty sure this should be fixed, closing.

Note You need to log in before you can comment on or make changes to this bug.