Bug 278861 - Edit->Preferences; Edit Profiles... seg faults
Edit->Preferences; Edit Profiles... seg faults
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: sound-juicer (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-05 13:24 EDT by Tom London
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 2.20.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 11:14:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom London 2007-09-05 13:24:54 EDT
Description of problem:
Selecting 'Edit Profiles...' from Edit->Preferences causes a seg fault:

[New Thread -1218720880 (LWP 9303)]
[New Thread -1229210736 (LWP 9304)]
[Thread -1229210736 (LWP 9304) exited]
[Thread -1218720880 (LWP 9303) exited]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1208748256 (LWP 9286)]
0x00be9f22 in _g_utf8_normalize_wc (
    str=0xe5890000 <Address 0xe5890000 out of bounds>, max_len=-1, 
    mode=G_NORMALIZE_ALL_COMPOSE) at gunidecomp.c:364
364       while ((max_len < 0 || p < str + max_len) && *p)
(gdb) where
#0  0x00be9f22 in _g_utf8_normalize_wc (
    str=0xe5890000 <Address 0xe5890000 out of bounds>, max_len=-1, 
    mode=G_NORMALIZE_ALL_COMPOSE) at gunidecomp.c:364
#1  0x00be946e in IA__g_utf8_collate (str1=0x9ed2878 "Voice, Lossy", 
    str2=0xe5890000 <Address 0xe5890000 out of bounds>) at gunicollate.c:81
#2  0x00161fab in ?? () from /usr/lib/libgnome-media-profiles.so.0
#3  0x00bbbd16 in g_list_sort_real (list=<value optimized out>, 
    compare_func=0x161f70, user_data=0x0) at glist.c:583
#4  0x00bbbcd6 in g_list_sort_real (list=0xa3f9ea0, compare_func=0x161f70, 
    user_data=0x0) at glist.c:629
#5  0x00bbbce5 in g_list_sort_real (list=0xa3f9ea0, compare_func=0x161f70, 
    user_data=0x0) at glist.c:629
#6  0x00161a1d in gm_audio_profile_get_list ()
   from /usr/lib/libgnome-media-profiles.so.0
#7  0x001636cc in ?? () from /usr/lib/libgnome-media-profiles.so.0
#8  0x001641c8 in ?? () from /usr/lib/libgnome-media-profiles.so.0
#9  0x00b7598a in IA__g_type_create_instance (type=170604392) at gtype.c:1569
#10 0x00b5d172 in g_object_constructor (type=170604392, 
    n_construct_properties=2, construct_params=0xa18d720) at gobject.c:1046
#11 0x00b5ad8b in IA__g_object_newv (object_type=170604392, n_parameters=0, 
    parameters=0x0) at gobject.c:937
#12 0x00b5b92f in IA__g_object_new_valist (object_type=170604392, 
    first_property_name=0x0, var_args=<value optimized out>) at gobject.c:986
---Type <return> to continue, or q <return> to quit---
#13 0x00b5bae0 in IA__g_object_new (object_type=170604392, 
    first_property_name=0x0) at gobject.c:795
#14 0x00163b92 in gm_audio_profiles_edit_new ()
   from /usr/lib/libgnome-media-profiles.so.0
#15 0x080567de in prefs_edit_profile_clicked (button=0x9e4e568, user_data=0x0)
    at sj-prefs.c:155
#16 0x00b633a9 in IA__g_cclosure_marshal_VOID__VOID (closure=0xa1ad518, 
    return_value=0x0, n_param_values=1, param_values=0xbfbaa44c, 
    invocation_hint=0xbfbaa35c, marshal_data=0x80567b0) at gmarshal.c:77
#17 0x00b55f53 in IA__g_closure_invoke (closure=0xa1ad518, return_value=0x0, 
    n_param_values=1, param_values=0xbfbaa44c, invocation_hint=0xbfbaa35c)
    at gclosure.c:490
#18 0x00b666a3 in signal_emit_unlocked_R (node=0x9f27038, detail=0, 
    instance=0x9e4e568, emission_return=0x0, instance_and_params=0xbfbaa44c)
    at gsignal.c:2440
#19 0x00b67bc7 in IA__g_signal_emit_valist (instance=0x9e4e568, signal_id=216, 
    detail=0, var_args=0xbfbaa68c "�q�") at gsignal.c:2199
#20 0x00b67d89 in IA__g_signal_emit (instance=0x9e4e568, signal_id=216, 
    detail=0) at gsignal.c:2243
#21 0x005732b7 in gtk_button_clicked () from /usr/lib/libgtk-x11-2.0.so.0
#22 0x0057541e in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#23 0x00b633a9 in IA__g_cclosure_marshal_VOID__VOID (closure=0x9f27a28, 
    return_value=0x0, n_param_values=1, param_values=0xbfbaa90c, 
---Type <return> to continue, or q <return> to quit---
    invocation_hint=0xbfbaa81c, marshal_data=0x5753e0) at gmarshal.c:77
#24 0x00b54749 in g_type_class_meta_marshal (closure=0x9f27a28, 
    return_value=0x0, n_param_values=1, param_values=0xbfbaa90c, 
    invocation_hint=0xbfbaa81c, marshal_data=0x1a4) at gclosure.c:567
#25 0x00b55f53 in IA__g_closure_invoke (closure=0x9f27a28, return_value=0x0, 
    n_param_values=1, param_values=0xbfbaa90c, invocation_hint=0xbfbaa81c)
    at gclosure.c:490
#26 0x00b66b3a in signal_emit_unlocked_R (node=0x9f27a50, detail=0, 
    instance=0x9e4e568, emission_return=0x0, instance_and_params=0xbfbaa90c)
    at gsignal.c:2370
#27 0x00b67bc7 in IA__g_signal_emit_valist (instance=0x9e4e568, signal_id=215, 
    detail=0, var_args=0xbfbaab4c "0~\220") at gsignal.c:2199
#28 0x00b67d89 in IA__g_signal_emit (instance=0x9e4e568, signal_id=215, 
    detail=0) at gsignal.c:2243
#29 0x00573347 in gtk_button_released () from /usr/lib/libgtk-x11-2.0.so.0
#30 0x005733c2 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#31 0x00667fa2 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#32 0x00b54749 in g_type_class_meta_marshal (closure=0x9eddc08, 
    return_value=0xbfbaad10, n_param_values=2, param_values=0xbfbaadec, 
    invocation_hint=0xbfbaacfc, marshal_data=0xb4) at gclosure.c:567
#33 0x00b55f53 in IA__g_closure_invoke (closure=0x9eddc08, 
    return_value=0xbfbaad10, n_param_values=2, param_values=0xbfbaadec, 
    invocation_hint=0xbfbaacfc) at gclosure.c:490
---Type <return> to continue, or q <return> to quit---
#34 0x00b66cf3 in signal_emit_unlocked_R (node=0x9eddcc0, detail=0, 
    instance=0x9e4e568, emission_return=0xbfbaafac, 
    instance_and_params=0xbfbaadec) at gsignal.c:2478
#35 0x00b6798f in IA__g_signal_emit_valist (instance=0x9e4e568, signal_id=69, 
    detail=0, var_args=<value optimized out>) at gsignal.c:2209
#36 0x00b67d89 in IA__g_signal_emit (instance=0x9e4e568, signal_id=69, 
    detail=0) at gsignal.c:2243
#37 0x007a1868 in ?? () from /usr/lib/libgtk-x11-2.0.so.0
#38 0x0065feae in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#39 0x00661282 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#40 0x0095176a in ?? () from /usr/lib/libgdk-x11-2.0.so.0
#41 0x00bbe17c in IA__g_main_context_dispatch (context=0x9eba0b0)
    at gmain.c:2061
#42 0x00bc15bf in g_main_context_iterate (context=0x9eba0b0, block=1, 
    dispatch=1, self=0x9e01458) at gmain.c:2694
#43 0x00bc1969 in IA__g_main_loop_run (loop=0xa260fd8) at gmain.c:2898
#44 0x00661714 in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#45 0x08055824 in main (argc=1, argv=0xbfbab3d4) at sj-main.c:1560
(gdb) 
(gdb) 


Version-Release number of selected component (if applicable):
sound-juicer-2.19.3-3.fc8

How reproducible:
Every time

Steps to Reproduce:
1. Edit->Preferences
2. Click on 'Edit Profiles....'
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Bastien Nocera 2007-09-06 11:23:21 EDT
Which version of gnome-media are you using?
Could you please attach the output this command as a file as well?
$ gconftool-2 -R /system/gstreamer/0.10
Comment 2 Tom London 2007-09-06 15:21:31 EDT
I'm running latest rawhide:

[root@localhost ~]# rpm -q gnome-media
gnome-media-2.18.0-6.fc8
[root@localhost ~]# 

[tbl@localhost ~]$ gconftool-2 -R /system/gstreamer/0.10
 /system/gstreamer/0.10/audio:
  /system/gstreamer/0.10/audio/profiles:
   /system/gstreamer/0.10/audio/profiles/voicelossless:
    extension = wav
    active = true
    description = Used for converting to lossless voice-quality audio. Use this
for recording and editing speech.
    name = Voice, Lossless
    pipeline = audio/x-raw-int,rate=22050,channels=1 ! wavenc name=enc
   /system/gstreamer/0.10/audio/profiles/cdlossless:
    extension = flac
    active = true
    description = Used for converting to CD-quality audio, but with a lossless
compression codec. Use this if you later want to edit the file or burn it to CD.
    name = CD Quality, Lossless
    pipeline = audio/x-raw-int,rate=44100,channels=2 ! flacenc name=enc
   /system/gstreamer/0.10/audio/profiles/aac:
    extension = m4a
    active = true
    description = Used for converting to CD-quality audio, but with the lossy
AAC codec. Use this for preparing files for copying to devices that only support
the AAC codec. Note that using this format may be illegal in your jurisdiction;
contact your lawyer for advice.
    name = CD Quality, AAC
    pipeline = audio/x-raw-int,rate=44100,channels=2 ! faac ! ffmux_mp4
   /system/gstreamer/0.10/audio/profiles/cdlossy:
    extension = ogg
    active = true
    description = Used for converting to CD-quality audio, but with a lossy
compression codec. Use this for CD extraction and radio recordings.
    name = CD Quality, Lossy
    pipeline = audio/x-raw-float,rate=44100,channels=2 ! vorbisenc name=enc
quality=0.5 ! oggmux
   /system/gstreamer/0.10/audio/profiles/voicelossy:
    extension = spx
    active = true
    description = Used for converting to lossy voice-quality audio. Use this for
recording speech that doesn't need to be edited.
    name = Voice, Lossy
    pipeline = speexenc name=enc ! oggmux
   /system/gstreamer/0.10/audio/profiles/mp3:
    extension = mp3
    active = true
    description = Used for converting to CD-quality audio, but with the lossy
MP3 codec. Use this for preparing files for copying to devices that only support
the MP3 codec. Note that using this format may be illegal in your jurisdiction;
contact your lawyer for advice.
    name = CD Quality, MP3
    pipeline = audio/x-raw-int,rate=44100,channels=2 ! lame name=enc mode=0
vbr-quality=6 ! id3v2mux
  /system/gstreamer/0.10/audio/global:
   profile_list = [cdlossy,cdlossless,aac,mp3,voicelossy,voicelossless]
 /system/gstreamer/0.10/default:
  videosink = autovideosink
  chataudiosink = autoaudiosink
  musicaudiosink_description = Autodetect
  audiosrc = halaudiosrc
udi=/org/freedesktop/Hal/devices/pci_8086_27d8_alsa_capture_0
  videosrc = v4lsrc
  audiosink = autoaudiosink
  musicaudiosink = autoaudiosink
  visualization = goom
  audiosink_description = Autodetect
  chataudiosink_description = Autodetect
  audiosrc_description = AD198x Analog
[tbl@localhost ~]$ 
[tbl@localhost ~]$ 
Comment 3 Bastien Nocera 2007-09-20 11:14:26 EDT
Fixed in 2.20.0-2, the problem was the upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=440400

Packages at:
http://koji.fedoraproject.org/koji/taskinfo?taskID=167541

Note You need to log in before you can comment on or make changes to this bug.