Bug 278951 - traceback keyerror chroot from %post scripts
traceback keyerror chroot from %post scripts
Status: CLOSED DUPLICATE of bug 276851
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
All Linux
medium Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-09-05 13:59 EDT by Bill Peck
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-09-05 14:02:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bill Peck 2007-09-05 13:59:57 EDT
Description of problem:
Anaconda tracebacks from kickstart install

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. kickstart install with %post sections

Additional info:

     ^MRunning anaconda, the Fedora system installer - please
wait...^MProbing for video card:   ATI Technologies Inc Rage XL^M              
         Graphical installation not available...  Starting text mode.^M        
         ^[[1;24r^[(B^[)0^[[1;24r^[[H^[[J^[[1;1HTraceback (most recent call
last):         File "/usr/bin/anaconda", line 916, in <module>   
kickstart.processKickstartFile(anaconda, opts.ksfile)  File
"/usr/lib/anaconda/kickstart.py", line 829, in processKickstartFile   
File "/usr/lib/python2.5/site-packages/pykickstart/parser.py", line 653, in
readKickstart    self._stateMachine (lambda: fh.readline())  File
"/usr/lib/python2.5/site-packages/pykickstart/parser.py", line 611, in
_stateMachine    self.addScript()  File "/usr/lib/anaconda/kickstart.py", line
750, in addScript    self._script["chroot"], self._script["log"],KeyError:
'chroot'install exited abnormally [1/1]
Comment 1 Chris Lumens 2007-09-05 14:02:01 EDT

*** This bug has been marked as a duplicate of 276851 ***

Note You need to log in before you can comment on or make changes to this bug.