Bug 279011 - change from sysreport to sosreport breaks hardware certification
change from sysreport to sosreport breaks hardware certification
Status: CLOSED DUPLICATE of bug 294771
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sysreport (Show other bugs)
5.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Navid Sheikhol-Eslami
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-05 14:26 EDT by Doug Chapman
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 14:52:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2007-09-05 14:26:40 EDT
Description of problem:
We are seeing this warning when running the hts test suite:

cp: cannot stat `this': No such file or directory


This was seen just as it was finishing up running "hts certify --test memory" on
an ia64 full-virt guest.  The test run was otherwise successful.

Here is the message in more context:

Creating compressed archive...



Your sosreport has been generated and saved in:

  /tmp/sosreport-hp_fv_1-356410-ff7197.tar.bz2



The md5sum is: 628a0fe97d54fb0477d64b24e5ff7197



Please send this file to your support representative.



cp: cannot stat `this': No such file or directory

+ rpm -ql kernel-2.6.18-43.el5

  Checking kernel Ok. 

...finished running ./info.sh, exit code=0

recovered exit code=0

hts-report-result info PASS /var/log/hts/runs/1/info/output.log 

saveOutput: /var/log/hts/runs/1/info/output.log

Return value was 0



Version-Release number of selected component (if applicable):
hts-5.0-50.el5


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Greg Nichols 2007-09-18 12:09:20 EDT
This error occurs because sysreport was replaced by sosreport in RHEL 5.1,
breaking HTS's integration, as it's looking for the archive the tool produces
based on specific prompts.    

Moving bug over to the RHEL Beta product, as the old prompts should be supported.
Comment 4 Navid Sheikhol-Eslami 2007-09-19 14:49:23 EDT
Looks like the same problem I addressed with the latest re-spin in
RHEA-2007:0855. See BZ#294771.

Please the candidate for errata (sos-1.7-9.1.el5)
http://brewweb.devel.redhat.com/brew/rpminfo?rpmID=1032624

Thanks.

-- Navid
Comment 5 Navid Sheikhol-Eslami 2007-09-19 19:06:51 EDT
Errata candidate RPM can be found here:
http://porkchop.devel.redhat.com/brewroot/packages/sos/1.7/9.1.el5/noarch/sos-1.7-9.1.el5.noarch.rpm

-- Navid
Comment 6 Doug Chapman 2007-09-19 23:24:17 EDT
This BZ is in needinfo state however I am unable to see any question.  it
appears there are several private comments which I cannot see.  If you have a
question for me please make that comment non-private.
Comment 7 Marco Bill-Peter 2007-09-19 23:49:19 EDT
opened comments #5 and #4 for Doug

marco
Comment 8 Suzanne Yeghiayan 2007-09-20 11:38:42 EDT
Doug, this bz appears to be a duplicate of bug 294771 but we'd like you to
verify that before we CLOSED/DUP this bug.
Comment 9 Doug Chapman 2007-09-24 14:52:18 EDT
(In reply to comment #8)
> Doug, this bz appears to be a duplicate of bug 294771 but we'd like you to
> verify that before we CLOSED/DUP this bug.

I updated to the latest sos as described in comment #5 and it does indeed fix
the issue I was hitting.  I will close this BZ as a dup.


*** This bug has been marked as a duplicate of 294771 ***

Note You need to log in before you can comment on or make changes to this bug.